Can't deactivate colors of normal maps

I’ve been searching for a lot of tutorials for normal mapping, but i have a little problem which i need help.

It’s not too much

I’m following this tutorial of blendertuts (

What i do:

  1. Successfully render the normal map
  2. Set Viewport in GLSL
  3. Add new material to low poly model
  4. Add new texture to material of type “Image or movie”
  5. Set Image Sappling as “Normal Texture”
  6. Set Mapping as UVMap
  7. in Influence Check Geometry:normal = true and Diffuse:color = false

But when i uncheck the color on diffuses, stills shows the color of the normal map, not like in the video in 9:36.
What i’m missing?

P.S. I’m attaching a small .blend with “my problem” and a picture with my settings


normal_maps_try.blend (522 KB)

Try with the blend file you attached. Maybe because you are not using a saved image file in your screenshot (using a generated image) but you are in the file you attached
Opened it and enabled Normal influence, image in 3d view and render was correct, not showing the normal map colour.

Actually in the render appears fine, but still can’t make it in realtime on the viewport.

Other blender settings are by default

Well, actually in the tutorial i was following, in fact he used a generated image, but i still tried with the file i attached and still shows me the colors.

I used a pc with a radeon 9200 and this is a intel HD graphics 2000