Can't edit a curve-path with a camera parented to it?


(Twansparant) #1

Hi there,
I have a problem with a curve-path, it’s probably something really small, but I can’t figure it out. I made a bezier-curve for a camera to follow it. I set the curve to "curve-path"in the curve settings. With the path selected I insert a “curve-key” which appears in the IPO-curve editor in “IPO-type vertex” so I can adjust the speed along the path. Then I parented the camera to the curve with "follow track"with a path-length of 400 frames, I also set the camera “track to constraint” to a empty in the scene. That’s going fine! :wink: No problems, but now I want to adjust the curve, so I jump to Edit-mode, and I grab a vertice or add one by subdividing.
Now here’s my problem [!] : when I jump back to object mode, the changes I made to the curve disappear! Also when I go back to Edit mode again, the changes I made are gone! What am I doing wrong? Can anyone help me?
Thanx anyway!


(Fligh) #2

Do you have AVK’s or RVK’s set on the curve (look in the IPO window menu).

%<


(AndyD) #3

Edit:
I 've removed this to avoid confusion :slight_smile:


(Twansparant) #4

I think that’s the problem, when I press “Insert” key in the 3D window, I don’t get the question relative or absolute keys.
And in the IPO-window, the IPO-curve doesn’t appear in “path-IPO type”, but in “vertex-IPO type”. Any idea? Thanx! :wink:


(Fligh) #5

Delete the Vertex keys.

In the IPO window header menu select Path and the only option in the Right-Hand column is “Speed”. Left-click it to select it and Ctrl-LMB on the grid to add keyfames or inserts as you call them.

%<


(AndyD) #6

Damn you’re right. I looked and looked and concluded I must have used “Time” when I did this previously.


(Twansparant) #7

Yup, that was it!
I made an IPO-curve with the speed!
Thanks for your help! :smiley:


(patdog) #8

Glad that one got sorted out :wink: Thanks guys!