Can't edit object or apply materials: questions about groups, parents or links

I have a situation where I can’t apply a material to an object or edit it at all. The object in question is linked from another file, but I don’t know exactly how I did it or what the name of the process is. It’s been awhile since I made this object and I was following an exercise in a book. Therefore it’s challenging for me to figure out how to fix it.

The object has an orange outline and its own axis.


In the outliner there is a group icon next to it that when the cursor hovers over it gives me the URL of the object on my local machine.

My questions are, what is this type of linking is this and how to I break it so that I can apply materials? I’ve tried to unlink it or ungroup it using conventional methods but that is not working.

Have you tried to bring it into the scene as append and not link?

Looks like using append recreates the situation slightly. However it looks like I can change the materials of the things I can append. I can’t do that with the objects I’m currently working with.

Linking objects is just that, you are linking a complete object. For example if working on a city scene and decide you have an awesome car that you completed and want in the scene you can just link it as it doesn’t need any editing. However if you decide you want to change geometry or materials you would append the car into the scene and therefore you can edit geometry and materials. A blend file might help diagnose more if appending the object doesn’t work.

Here is a link in depth to what I’m talking about.
https://docs.blender.org/manual/en/dev/data_system/linked_libraries.html

Hey, observing from what your screen shots show: the first pic shows 2 objects selected - the ‘leg’ or what ever & an ‘empty’ (that’s not an axis). The reason I say that is your second pic proves that, ‘LEG’ has the symbol for an ‘EMPTY’. Click on the ‘+’ sign next to it, my guess is its the ‘Parent’ of the object your trying to get to. 'Empty’s do not have a provision for ‘materials’.

In version 2.75 the outline is blue for ‘Linked’ in objects.

Blender doesn’t let me make the objects local but it does allow me to make a proxy. I’m having trouble understanding this sentence from the manual.

Appending data you already have linked will add objects/groups to the scene, but will keep them linked (and un-editable).

Does that refer to things you have linked in another file and then appended?

What’s the best way to post a blend file for review?

https://blenderartists.org/forum/attachment.php?attachmentid=285171&d=1390742710

RFP5.blend (849 KB)
RFP_leg.blend (721 KB)

Thanks!

I was able to re-append the leg to the bench and apply materials and everything. I have no idea what I did to get the file in the state that it is in.

Glad you got it figured out. It took me a while when I first started using Blender to figure out the difference between link and append but anymore about 90% of the time I use append if I need to bring in another blend file into my current file. Good to know I was somewhat helpful.

Yeah, thanks for the assistance!