Can't Extrude Curves/Path [Blender 2.54]

Hello,
I tried to extrude a path to extend it, but pressing E seems to make it act like I’m just grabbing it. It doesn’t appear to add a new point either.
So I tried a bezier curve instead, pressing seems to make another point on top of the other and pointing in the opposite direction.
Am I doing something wrong or is this a bug?

To illustrate, take - as lines of the curve and . as points:
I start with:
.-.
I extrude and get:
.—.
I want:
.-.—.

Thanks

Hello, alexgeek.
It seems to me, that I found possible solution. I created a simple scene to show it.


curves.blend (393 KB)

The idea is to create 2 different curves: one is the path and other is the figure, which you want to extrude along this path. On my screenshot objects 1 and 3 are bezier curves made to form needed figure, 2 and 4 are paths. To do so, create and select “path” curve, click “curve” bookmark and in the field “Bevel object” specify another curve. It should be extruded along the path. For example, plinth can be formed so.
Figure 5 was created by another method. Create bezier curve, convert it into mesh by alt+c, and then extrude its vertices as usually.
Hope it will help you.

Not sure if it is a bug or not since it is working fine for the others, however your workflow isn’t explained very well. I think in the first part of your post when you say you use ‘e’ all of the points on the curve are selected, which does cause all of the points to move as if you are grabbing it. Specify one point and extrude from there or specify a point and Ctrl left click a new point somewhere.

I would also get a Blender 2.57 build as there may have been an issue with the build you are using now that has since been fixed, although I have not seen issues like this with curves in many builds since early 2.5x development.