Can't figure out what's wrong with my UI.

Hey =)
I installed Blender a few months ago but didn’t have the time to work on it untill now, so I’m working with version 2.49b. I started watching the video tutorials and I got to the third one, where I got stuck. It seems that the UI I see in the video is nothing like the one I have:

I’ve managed to work it out untill 5:39 where he switched from “Object Mode” to “Edit Mode”. I tried doing so, but the drop down list I have contains only one item. (“Object Mode”)

I tried resetting the UI by clicking “Load Factory Settings” but I still get the same UI… can anyone please tell me how I get to the same UI shown in the video? Should I download the newest version? is that the problem?


EDIT: Turns out blender weight’s less than 30Mb so it took me 5 minutes to install the newest version, that had the UI I was looking for. thanks for reading this anyway :slight_smile:

Glad you figured out what was wrong,and got your Blender 2.57b installed. ( even though I spent the time to type out an answer for you and you posted your edit about 2 seconds before I pressed the Submit button. :stuck_out_tongue: …lol)

Happy Blendering