Can't find Appended Objects in Blender 2.7


I’m trying to Append an object from another .blend file, and after selecting the object from the folders associated with the file I’m trying to bring in, it doesn’t seem to show up.

It is listed in the Outliner, and when I select it through the Outliner, the object’s dimensions show up on the Properties panel, but it is not displayed in either object mode or edit mode.

Same thing when I try to import it as a wavefront (.obj file).

I’ve tried altering the scale on the imported original, and that scale matches up in the destination .blend file, but I just can’t see it.

** A strange thing is that in a 2nd “testing” file, the object imports as both an .obj file and as a .blend. The main differences I notice is much lower complexity of modeling in the 2nd testing file, there is some animation in the testing file, and on the first file there is an un-applied mirror modifier being used.

Any suggestions? I am stumped.


Is it very very large or very very small ?
Are you looking on the correct layer
Is the object in the 3d view clipping range ?
Is the object out of your view
Is it hidden (look in outliner)
Is your 3d curser in view before you append
Have you tried selecting the object in the outliner and zooming in on it with Numpad. key

Supply a blend file with the object appended


Thanks so much.

I had inadvertently turned the display of layers selection boxes off in the header of my 3d view by hitting the " ` " key. Or was that " ~ " (tilde)? Ugh, the trials of noobism.

I’m wondering if the appended object was really coming in on a different, hidden layer or if this is a bug?

Thanks for a double assist today.