Can't flip normals in 2.64

Hi all,

I’ve installed 2.64 a few days ago, and it used to work fine. But since about two days ago, when I select the mesh, go to edit mode, and press the “Flip Direction” button at the Normals part of the panel, nothing happens. No error message, no change in the mesh, no change in the 3D view, no change in the rendered image.

I tried to apply location, rotation, and scale to the mesh before trying to flip the normals, but it didn’t help.

I can’t remember doing anything special. Loading the factory settings didn’t help. Also, I’m absolutely sure this function used to work fine, I created a few interior scenes where the room is an inside-out box, so I used it quite a few times.

What have I done wrong?

(My OS is Windows 7 64-bit, and I’m running the 64-bit build of Blender.)

Did you enable face normal display and see them not flipping?
(Screenshot by Olson. Used with permission)

Also check for doubles (edit mode, select all, w -> remove doubles, F6 to grow merge distance if needed).

Okay, with the face normal display turned on, it seems that they are flipped, but in the 3D view, the mesh still appears with its faces outside, and I can’t work inside of it if I can’t see what’s inside.

Check under Shading, there is a newer option to check backface culling. If that is checked then you wont see your faces. Its listed on the right hand side of your veiwport under display.

That’s fixed it, thank you!