Can't get alpha texture to render properly.

First of all, I just joined. I have about 7 hours of experience with Blender, I got it today and I’m liking it very much, I’ve followed some tutorials to get some things done, but I have ran into a problem that I can’t seem to solve by myself.


I uploaded the blend file in question to .

There is a plane to which I added a red carpet design (.png with alpha transparency around it), on the 3D view, it shows up correctly. However if you render the scene, there is a white border around the carpet, this is supposed to be transparent… I’ve spent a long time trying to figure out what to do but I can’t seem to fix it.

I hope someone can show me the right direction, thanks in advance.

Pedro Ferreira

Welcome to Blender Rohlan, hope you like it, we all do. As for your problem my guess is that your texture is slightly smaller than your object itself. Set the texture to “extend” instead of “clip” in the texture buttons panel. (Editing and then textures, looks like a leopard skin).

Thank you for helping, but it didn’t work.

Unrelated to the main questiom, but how can one tell if a texture is bigger or smaller than the object? the texture is 500x500 but I don’t know the size of the object.

I re-did everything, and voila, it is now working, I removed the UV Map and made it just a texture, ticked Alpha on the options and gave alpha a value of 0, and it works.

Yay me :slight_smile:

Hi, if you are using a UV map you should add the map as an image type texture in the texture window. in the map to tab select “UV” as the mapping type.

this is superior to just using texface since you have access to all the different mapping types that you would use with normal procedural or image textures. texface just applies the map as face color. using an image mapped with UV coordinates, you can map to bump, alpha, color, etc, etc, everything you would expect.

For a plane it doesn’t matter much, but for more complex meshes it allows for the flexibility of UV mapping along with the mapping options.

hope that helps.