Can't get .blend files to associate with Blender

Hello,

I reinstalled Blender 2.47 (Window XP) from the zip file instead
of the installer so I could still keep the scripts folder in the Blender
folder. The only problem now is all the .blend files just won’t open
with Blender. I tried right clicking the files>Properties and then
change the file it opens with, but it would not let me add Blender
to the list.

Finally I went to Folder View Options and found another way to
associate them, but they still won’t open with Blender. The
Blender logo won’t show up on them. When I double click a
.blend file, Blender opens and then says: “can’t open file C:\Documents”.

I can at least open them from starting Blender then File>Open, but
that’s it.

Anyone have a clue why this is happening?

I couldn’t find any other place that might have been appropriate to post this
so please don’t get mad.

Why not just stick with Blender 2.46?

Because there is 2.47.

Anyway. I got it working again somehow. I downloaded the self extracting
version and integrated it with the one I manually places in the Program Files.
The reason I manually paced it was because the installer version does not
put the .blend folder or any of the python scritps or plugins in there with it.
Who know’s where they go if there even there. So I was just doing what
someone suggested.

After integrating it, I kept trying to re-associate the file.
At first it didn’t have the icon, but could open from a double click (which is good)
and re-associated over and over and then the icon decided to come back
and everything is back to normal.

What a ride.

What’s so great about blender 2.47? I don’t think it’s got many new features. Just some bug fixes, and some very irritating problems like ghost train just mentioned.

The problem there was caused by using the .zip file & not the installer.
When the installer is used, it registers Blender in Windows.
So Windows will find Blender all the time.
When you simply unzip the files, there is no data registration.
It is a bug with Windows that Ghost_Train experienced.
Not a problem with Blender.
I have experienced the same problem.
Currently I use 4 different versions of 2.47.
(Standard 2.47, Custom 2.47, Apricot 2.47.1, Latest SVN 2.47.1)
This confuses the $&!# outta Windows.

Note, if I do Open a blend via Windows, it is the EXE (Standard 2.47)
that opens it, which is never what I want.
So for me, it’s using Blender File Menus all the way.

That it is a bugfix release. If you just move some vertices back and forth its fine to stick with 2.46. If you do more you´d like to change to 2.47. Some of the bugfixes are listed here
Kudos to the DEVs here. That was fast considering the releasedate of 2.46

However on topic, I simply re-assigned the .blend MIME handler to the new blender.exe in the explorer menu and replaced the (for me) “blender2.46/blender.exe” in the registry everywhere to “blender2.47/blender.exe”

The dirty version is to install or have installed 2.46 and simply copy 2.47 over 2.46.