Can't get mesh sliders to work in the Action Editor

Hi Blender Folk:
I am on the Final Animation page of the excellent “BSoD/Introduction to Character Animation” tutorial. (Thank you Ryan Dale!) I have just completed adding the shape keys for the lip syncing to the NLA editor, and seen my character walk and talk at the same time. What a thrill!
However, I can’t seem to get the “Adding a Blink” part of the tutorial to work. Having once succeeded in adding shape keys to the NLA Editor, I can’t seem to get back to the point in the Action Editor where I can move a slider and see it result in a change in the character’s expression while a key gets added to the timeline. I have followed the tutorial directions exactly under “Adding Blinks:” Select the armature, Set the armature to Rest Position, Select the Character Mesh, Select “Add New” from the menu at the bottom of the Action Window… At this point, the left hand column of the Action Window has the words, “Object,” and “Shape” in it. If I click on “Shape,” “IPO Curves” appears under it, and if I click on that, I see the keys I made for the character’s lip sync actions, but there are no sliders. If I click the black “X” to the left of the menu window, it brings up the sliders and an empty timeline with no keys. If I move one of these sliders, the whole Action Window goes back to just the word “Shape,” with one key and no sliders. How do I get to the point in the Action Editor where I have working sliders again? Thanks.

Is there a good tutorial somewhere on the NLA editor? Particularly how to use it with meshes? Thanks.

Hopefully these will suffice. :yes:

The Essential Blender also has a good tutorial on the nla editor in the
animation chapter.

Once you have expanded out “Shape”>>“IPO Curves” in the Action Editor, go to the “View” menu and choose the “Show Sliders” option. If the sliders don’t appear yet, click on the “Shape” channel’s name to select it (the name will now be shown with white text).


Thanks Sergeant_Oreo, I will give those tutorials a try.
Thanks Aligorith. I already had “Show Sliders” checked, nothing there but a blank column, even when I click on a Shape channel’s name. Also, the names of the channels as they appear under “Shape” are “key 1, key 2,” etc, not what I named them: “Upper lid, lower lid, etc.” I have a feeling I missed an important setting or button somewhere.
I have uploaded the .blend file to
If you have time to look at it, I would appreciate any help you can give. Thanks.

Hi List,
I figured out a work-around for getting two different mesh actions into the NLA editor. It is different from the method in BSoD: Introduction to Character Animation Tutorial, but it works. I have posted a set of directions along with a link to example files and a screen shot in the Tutorials list, BSoD: introduction to Character Animation Tutorial thread, last page, titled “Figured Out the Blink Problem.” Hope this helps someone else.

I’m having the same problem :frowning:

I’m trying to fine tune the lip sync animation, but I can’t get back to the breakdown of the shape keys in the action editor. The only way I can get the sliders for “wide”, “narrow”, “raise eyebrows” etc. is to get rid of all the actions, but then i’d have to start from fresh, bake the actions to the IPO window and then use the IPOs in the NLA editor again…

Could you provide a direct link to your post, Zaffer? I can’t find it anywhere…

Does anyone know if it’s possible to get the shape key information to display in the action editor after the action has been baked to IPO?.. All I can get is the “Shape” information, and this only places a single line of markers in the action editor. Useless for tweaking the “lip sync” animation. Or is the only way to change it to edit the IPO curves?

Also, I can’t add another animation using those shape keys…

This is the situation I am in:

This is the situation that I want to be in:

However, as soon as I move one of the sliders in the action editor, an IPO curve is created, and I’m back to the same situation as in the first image, unable to use the sliders to create an animation. Only the new IPO key is shown, but all the sliders disappear.

I thought I was making good progress up until this point… :frowning:

Edit: Have checked both of the links given by Sergeant_Oreo, and they seem to be entirely on the subject of using the action editor with armatures, not shape keys… I can’t find any resources that seem to address this. Do I have to skip a stage in my education and go straight to assigning drivers for my shape keys so that I can reference the bones (used as drivers) in the action editor, rather than using the shape keys themselves? Would this even work?

OMG!!! I just needed to take off the “Shark Victim” button in the IPO editor!!

So sorry to bother you people… Been bashing my head against this issue for 3 hours now! HAHA :smiley:

(hope this helps others out there, and gave some people a good laugh ;))