Can't get rotation of stones and flowers groups right in Particle System

I’m following a tutorial here: He says that the particle system uses the y axis for up and down. So as directed I reoriented the stones and flower groups to rotate around the y axis. But when I go to the particle system, I am unable to get the flowers to rotate using Normal or Velocity Hair as he does in the tutorial. I had to use Object Y to make the flowers to stand up straight . For the stones, I could use velocity hair rotation with decent results, but a few of the stones are rotated on their edges. Can someone explain why I am having this problem and how to fix it?

This is what happens when I try to follow the tutorial:

Blend file:

Rotate the flower objects so they lay correctly then apply any rotation (Ctrl+A / Rotation)

Thanks for responding. I couldn’t change the rotation of the flowers and stones the way you have them. The stones would be upside down. The tutorial has the stones and the flowers all facing to the right. That wouldn’t work either. Anyway, I was able to use normal for the flowers. I still wish I understood more of what I was doing. He uses Alt-R and Alt-S to reset the flowers rotation and size. Is that the same as Ctr A and choosing rotation, size?

From the tutorial:

This is the rotation that worked, but it’s not like yours or the tutorial rotation:

But the stones and flowers are on top. (Some flowers are growing out of rocks though - not visible here)

I tried to rotate the flowers and rocks the way you have them in you posted image.

But this is what I got:

Can you tell me how to get the foliage (low-resolution) to rotate correctly? I Ctr. A and selected Rotate on each one in the group. The rotation I used is the one that’s shown in the tutorial. Then I tried all directions with no change. I tried making a new group , but that had no effect either. In the particle system, when I use normal in the rotation section, my foliage rotates in weird directions. When I select object y, most of the foliage is rotated correctly, but the fern and the grass are not. But in the group, I have them all rotated the same way. It doesn’t make sense. Also, why are flowers growing out of a rock? Any help would be appreciated.

Blend file:

Rotating the foliage place holders the same as in the tutorial:

And this is what I get:

The best result I could get in the rotation section of the particle system rotation was using the object y, but the results are pretty bad:

I have found that if you orient the object so that from top view, up is the top of the object, and down is the origin point, the objects emit correctly. You can then enable rotation, and set the phase at 1 and use random below that for some random rotation.

Here is your blend file with those adjustments made. I had to rotate teh objects to orient them correctly, and then apply rotation. I then had to flip the normals of the emitter plane. Forest 08.blend

Isn’t that what I already did? I don’t understand what you mean. I’m a beginner, so I know it’s something I’m not getting.

No, in your original file, from top view (7 on the num pad), you are looking top down on the low poly flowers. Hit 3 on the num pad, and then rotate them 90 degrees clockwise. Then select the objects and hit ctrl+a and appy rotation.
After you rotate the flowers properly, you need to flip the normals of the emitter plane or they will be pointing down.

My apologies, I never checked those low poly flowers…I think they have been rotated in edit mode…they need to be rotated in edit mode and the origin points re-set.

I went back and did the rotating in edit mode. I didn’t know it made a difference. In the video he rotates the objects in edit mode, but I thought it wouldn’t make a difference as long as the origin points were in the correct place. I still don’t know why the objects have to be rotated in edit mode, but I got the best results and I could use normal and velocity hair in the particle system rotation section like he does in the tutorial. If I’d only followed the tutorial’s direction, I wouldn’t have wasted everybody’s time… Thanks. I may have another unrelated problem substituting the hi-res for the place holder objects, but at least I got through this issue.

I still don’t know how to avoid intersections of the objects:

I still don’t know why the objects have to be rotated in edit mode

If you rotate in object mode you are giving the object some rotation.
If you rotate in edit mode you are not giving your obejct rotation, all you are doing is moving the location of each vertex inside the object.
You can apply the object rotation with Ctrl+A to get back to a rotation of 0, 0, 0 which is the same as the result you’d get rotating in edit mode.