Can't get the spot light to cast shadows?

I belive I have everything set up correctly.

I’m in a bit of a hurry, so I wont go into details. You can probably solve it quicker yourself just by looking at it.

I’m still new, this is basicly the 2nd thing I have tried to do; just trying to teach myself.

Here’s the file.

Youl see the spot light wont cast shadows (I hope).

Tell me what you did to get it to work, so I can know next time. Thanks.

Turn on “Ray” in scene buttons, and turn on “Ray shado” for your spot light.

and it will work :o :smiley:

Ken

Yes that will work.

The main problem though is the default settings are out of whack for your shadow lamp. To reset them delete your lamp and add a new one. Then just set it to spot and your defaults should be right to produce buffered shadows. Also you’ll want to connect the seams of your floor and walls cause there’s a light gap. And remove doubles too. (select all vertices/Wkey/Remove Doubles)

Show us the final render. Looks like a moody scene.

Thanks.

I keep reading from old questions that you can only do this with spot lights.
Or maybe I misunderstood?

Good to know you can do it with any type of light now. Thanks.

The new blender 2.32 has the ability to create shadows from all lamps, as well as ray tracing and translucency. :smiley:

Ken