Can't get transparent textures to work


I have an annoying problem with Blender. I essentially want to render some transparent polygons. Earlier I have done this by loading an image texture and mapping its transparency and colors to a plane. This works quite nicely

Now I want to preview the textures while modelling, so I have tried the UV editor. I can get the textures aligned and all, but the transparency just does not want to work. I have selected the ‘alpha’ blending mode and ZTransp for the material. The transparency only works on the preview window when the mesh is selected. When I unselect it, the transparency disappears (though the texture is still shown). Rendered pictures lack the transparency as well. I went through all the options I could find, but it just flat out refused to work.

Please help me fix this. I’m losing my hair as well as sanity quite fast.

turn the alpha slider all the way down. also click on ‘use alpha’, or ‘calc alpha’ in texture buttons.

Doesn’t work. It just makes the whole thing disappear. If I add the image as a texture in material menu it does not align itself to the coordinates set by the UV editor.

would it help if i put up a .blend with some examples of alpha textures? or if you would post an example of what you are trying to do, i could take a look at it.

I put an example of what I’m trying to do here. It has a background cube and two transparent textures. The left one has the image placed to a texture channel. It renders correctly (the cube shows through), but textured preview does not work. The right one is UV-mapped, and texture preview works if it is selected. When unselected or rendered the transparency does not work.

Strange, I can’t find anything wrong with your settings. I guess the solution would be not to use tex face.

But then I can’t use the UV editor or textured view.

It almost feels like there is one more alpha toggle switch hidden somewhere deep in the program, which I just can’t find.

I’m still stuck with this. Has anyone actually gotten transparent textures to work?

You can still use the UV editor you just don’t assign the matreials in it assign them in the material buttons.

Simply apply the material from the one that works during rendertime to the one that works during realtime and then…

In the Material buttons, under the [Map Input] Tab change your selection from Orco to UV.

That’s it. Now I got it to work. Thanks a lot! The only problem is that textured preview does not draw transparency correctly unless the object is selected. Seems like a bug in Blender.