Can't get UV Image to show as in Vehicle Modeling by BlenderCookie

I’m on the step where you open image in the image editor
but I can’t see any image.
See Video for screencapture of what’s happening:


I click that, select the image, but nothing still shows up.

Here’s a more direct video showing the difference between previous Blender versions and 2.62. Am not able to open image in UV editing layout.

Change from Edit mode to Object mode in the 3d view window

Try this too :
-in Edit Mode select the whole model
-Open the image

I noticed that for some very odd reason, if i am in Edit Mode and have nothing selected, the image will not appear in the UV Editor window despite i have loaded it (and it’s in the list too)

Thanks, that did it.
Appreciate it guys.

Okay, Jonathen just blew my mind, he hit tab to go into edit mode, and his picture still shows up on the UV editor.
Check out the screencast to see;


I figure he could do this because he was in object mode and hadn’t done any unwrapping or anything in edit mode yet when he loaded up the image.

You had probably unwrapped with no image loaded, or loaded an image then deleted, or something like that. So when you tabbed back to edit mode after loading an image, the image viewer popped back to the image the faces are mapped to… in this case, nothing (grey). Because…

When you are in edit mode with any faces selected, if you load an image into the editor that image gets mapped to the selected faces internally. Select different faces and load a second image and that image will be mapped to those faces… but you won’t see that second mapping unless you tab into object mode -textured display (apparently only the first loaded image is shown in edit mode). If you selected all and unwrapped with no image loaded, the faces got mapped to nothing. Select one of them and empty space will appear in the image editor.

… Or as Sanctuary mentioned, if you load an image while in edit mode no faces selected / mapped, the image will load but won’t come up in the editor. This trips up many people. The usual step not mentioned or missed in tutorials is select all faces then load image -with no explanation why.

This internal mapping shows on the object in the 3d view textured mode and in the game engine, but will not render unless a material is applied to the object and Properties > Material > Options > Face Textures is turned on (the quicky cheat way to preview textures in a render without loading them up the proper way).

If you would’ve clicked the “Pin” button in the image editor before you went to edit mode, the image would’ve stayed up. Whether that would’ve screwed up the next steps in that tutorial I don’t know.

Hope this helps…


Thanks for the long explanation.
I did no unwrapping though before uploading the picture.
Either I did have a vertex selected or not, don’t remember.
But I did the ‘pin’ button and it stayed for ‘object’ or ‘edit’ mode.
Hit ‘unpin’ selected all, uploaded photo, unselected and it was there, then
went to edit mode and it was still there. So not sure what exactly I did,
but when in ‘object’ and all is selected the pic is there, when in ‘edit’ mode
and all is selected, it is whited out with one cross of vertices and edges.
Confusing like you say, but can work with it now.