Can't go into game engine

whenever I press “p” to enter the game engine, blender freaks out and the screen flashes … makes it pretty difficult to do things. It does it a lot less in the Standalone mode when I am in full screen, but that gets pretty annoying…

Sometimes reinstalling it helps. Just maybe its that simple.

I’ve tried uninstalling it fully and then reinstalling it multiple times, no luck

Sounds like graphics card problem. Try in GLSL mode or in single-tex

How do I do that(that probably sounds horribly dumb but I need to know)

are you in blender game mode. if you don’t know glsl it is not set.

Up the top it says “Blender Render” Click on that and change to blender game.
Press T
Go to the display tab on the bar that just appeared. It will have a box with either “Single Texture” “Multi-texture” or “GLSL” in it.
Try each of those.

Also, what kind of computer do you have? Is it a laptop? A desktop? A piece of toast (LOL, just kidding)? We need to know to help you.

Haha, made my day before I’m even outta’ bed. :wink:

It’s an ASUS laptop

Also I went into the tool tab I can’t find the box saying either one of those modes on it.

What kind of ASUS laptop (more specifically, what kind of graphics card)? Not every graphics card supports the ‘best’ graphics options.

And here’s how to set the shading mode.

  1. Make sure the Render mode is set to Blender Game at the top.
  2. Make sure you’re on the Render tab on the right.
  3. Set the shading mode by selecting which mode to use. GLSL is for advanced graphics, like normal maps and shadows, while Single Texture mode is for simple graphics. Multi-texture is in the middle, a bit - it allows for using multiple textures, but no advanced features. If your graphics card can’t support GLSL mode, you probably want to go with Multitexture or SingleTexture mode.

I’ve gone into glsl now the only problem is the lighting is insanely bright, like it’s pretty much entirely white and it won’t support single texture

asus x53sv-rh51 it’s an ASUS notebook made for gaming it already has NVIDIA automatically installed 6 gigs of RAM 640 gig hardrive

thank you for helping, I’m a little technologically challenged with some of the things other people would say are the easiest things to do. PS I also thoroughly enjoyed the toast comment

This is getting kind of frustrating, I’ve only been having the issue just recently, I’ve used blender for a couple years now and have never had an issue like this.

Now that’s pretty useful to know. So did you do anything recently that might have altered your computer? Have you tried updating your graphics card driver? You say that it already has an NVIDIA card installed - what card is it? Is it just Blender, or any 3D application?

I haven’t done anything recently that I know of, the only 3d anything I have on my computer is blender and I think the card is GEFORCE GT540M also, I’ve been playing around a bit with blender and I made my object move(using the simple motion actuator) away from the starting point and it has been stabilizing and flickering a considerable amount less, I am running it on multitexture because GLSL is super bright and it’s better than single texture

then I added color and it went back to crazy

I consider myself quite adept at Blender but I still have this problem sporadically so I thought Id spend the morning trying to solve it.
The strange part about the problem is that it only seems to happen occasionally & only in some views.
DELETING THE CAMERA - removes the error - but leads to the same uber- “insanely bright” issues Ernst97 previously mentioned.
APPLYING SHADELESS to materials also removes the flicker problem but again causes the “insanely bright” issue.
Trying GLSL now to see how that helps things. I have attempted a skydome before now & that worked beautifully so its defo something to do with the texture/material/glsl/lighting… :-/
It would be nice to have a sticky somewhere that solves this issue - I believe its fairly common but there isn’t a onestop shop/thread solution as the problem is difficult to describe.

Im trying various combinations of buttons now…
This combination seems stable at the moment (but the problem is that the issue seems to be unpredictable)

1/a) Texture mode (not solid or wireframe or bounding box)
b) n Properties Toolbox - Display - tick Textured Solid
c) n Properties Toolbox - Display - select from Shading dropdown GLSL

seems to be working FOR NOW… 8-/