Can't install Blender on Ubuntu. Please help! [SOLVED]

Hi All,
I’ve been using Blender on Windows for 5 years and yesterday decided to try my hand at Linux which I have never touched before in my life. Needless to say installing Ubuntu was quite a culture shock! But after 9 hours I finally did it.
Now to get Blender!

I download the 64-Bit version from the Blender Downloads page and unpack it in my home directory (see attachment to see folder layout).

I go to the Blender folder, double click the Blender icon… nothing! It doesn’t load anything!
Hmmmm I think. "I’ve heard people have had to ‘compile’ programs to get them to work in linux’. So I open the terminal and type:

[email protected]:~$ cd blender
[email protected]:~/blender$ blender
The program ‘blender’ is currently not installed. You can install it by typing:
sudo apt-get install blender

bash: blender: command not found

But if I type sudo apt-get install blender as it suggests, I think it connects to Synaptic and downloads it from there? Because, whilst blender does load it’s only version 2.45 :o

I’ve searched the forums and people have recommended getting it from getdeb. But not only is that version 3 mbs smaller than the official version (what did they remove?) but according the comments it doesn’t even work properly.

So I would prefer to use the Official Blender release if possible.

Can someone please help me?
I would be very greatful.

Thanks in advance! :stuck_out_tongue:

Attachments


Hello and welcome to the wonderful world of Linux
9 hours to install?? You get a “world record” here, I guess?! :slight_smile:
If you use “Apt-get” ( maybe “hard” for beginers, use Synaptic instead?), you connect to your distribution repositories ( by default, you can add others), that are “out of date” a little.
But you can use the downloaded version, of course…your problem is:
you must type the complete path like for example:
/~/blender-2.46XXXXX/blender -W
or use the command cd /pathtotheblenderfolderhere
or go to the blender directory with your file manager, right mouse click and choose “open terminal here”, then type ./blender -W
the -W option is to open Blender full screen
Bye

hello,
i suggest you to install the blender from the repository as it also installs the dependencies and then you can start the downloaded 2.47 from it’s location as mentioned before:
./blender
or just simply (double)clicking on it in a file manager…creating a launcher makes it even easier to start.

Thanks OTO, but it’s still not working.
After going to the Blender directory, right clicking and saying “Open here in Terminal”, this is the error I get:

[email protected]:~/blender$ ./blender -W
./blender: error while loading shared libraries: libpython2.4.so.1.0: cannot open shared object file: <b>No such file or directory</b>

Now… I can clearly see that there is indeed a file called “blender” in that directory (see attachment), so why can’t Ubuntu?

Thanks again

Attachments


So just so I understand, by “repository” you mean using that program called Synapetic right?

After I install Blender 2.45 I then try and open blender like OTO said?

I’m not sure what dependencies are, but I assume they are hidden files that get buried at root to make certain programs work? Like the hidden files in Windows?

I’ll give this a try then report back.

Nope! Same problem. Says the same thing:

error while loading shared libraries: libpython2.4.so.1.0: cannot open shared object file: No such file or directory

Actually I just noticed it’s mentioned something about python. Doesn’t that come with the package?

redbyte, what version of ubuntu did you get?

Blender comes precompiled against either python 2.4 or 2.5. From your post, it seems you got Blender for python 2.4. To check the version of python you have installed, type:

dpkg -l python

and you should get something like this:

[email protected]:~$ dpkg -l python
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                                 Version                              Description
+++-====================================-====================================-========================================================================================
ii  python                               2.5.2-0ubuntu1                       An interactive high-level object-oriented language (default version)

if that is the case, you can just download blender for python 2.5 from blender.org. In my case, blender also complained about not finding another library (libalut0). I got it to work for me by typing

sudo apt-get install libalut0

As for switching to *buntu, I made this transition on the desktop last year. It is different at first, but I got used to it, then it paid off and I got more productive in the linux environment than I did on windows.

Hope this helps you.

I couldn’t get it to work on Ubuntu either.
I just gave up.
Linux could learn a lot from Windows. Like build an installer that you simply click install and it actually installs everything.

I tried Sabayon as well. And just to stir the pot a little more, hardware that Ubuntu detected fine, Sabayon could not. why can’t these Linux distros all use the same code, preferably the code that always works?

Ultimately I ended up begging on forums for help and getting snotty replies from people who spouted sudo and other mythical words that I am supposed to understand?

What button do I click on to make it work!

Ubuntu 8.04 64-Bit

I did what you suggested and these were my results:

<b>andrew:~$ dpkg -l python</b>
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
ii  python         2.5.2-0ubuntu1 An interactive high-level object-oriented la

So that means I have python 2.5 right?

Next I tried the libalut0 trick:


<b>andrew:~/blender$ sudo apt-get install libalut0</b>
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libalut0 is already the newest version.
The following packages were automatically installed and are no longer required:
  libavutil1d libavcodec1d gettext libgsm1 libdc1394-13 libavformat1d
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Confident I might be on to something, I ran the command to start blender!


<b>andrew:~/blender$ ./blender</b>
./blender: error while loading shared libraries: libpython2.4.so.1.0: cannot open shared object file: No such file or directory

So as you can see I’ve hit the same roadblock yet again. :no:

Anyone else have any ideas?
Thanks for helping me out guys

Haha, I can definitely relate to that. I felt exactly the same last night. You really just have to specify clearly that you haven’t used Linux before and don’t know any of the jargon.

I basically had no choice but to upgrade as I’m trying to render a short film involving lots of high resolution fluids, which apparently Windows has a hard time doing without crashing due to memory swapping problems.

I can’t wait to try it in Ubuntu! From what I can tell it is fast and reliable… once you wade through all the bull**** of course. :stuck_out_tongue:

First, some terminology: :smiley:
apt gets software from a repository on the Internet. apt is a front end to Debian’s dpkg that automagically installs and gets the right dependencies. Synaptic is a GUI front end to apt.
Dependencies are libraries that a program needs to run, kind of like .dll in Windows. For example, Python is one of Blender’s dependencies.

To install Blender:
First get rid of any Blender installation you have (this is probably not necessary, but we don’t want any extra confusion). To do this, delete the Blender folder you downloaded (deleting it in the file manager is sufficient), and uninstall the one from the repository, along with its dependencies:

sudo apt-get remove blender

and probably:

sudo apt-get autoremove

Now to install from the repository:

sudo apt-get install blender

Blender should now be installed. If you are in GNOME or XFCE, you can see if it opens with Applications>Graphics>Blender. To open it from a terminal, typing blender should be sufficient. Do this to see any error messages.

Since the build in the repos is outdated, you’ll want to install the current version of Blender. apt already figured out its dependencies and installed them for us. Just go to blender.org and download the corresponding build. Extract it to where you want it. Run it by double clicking on the icon, or opening a Terminal in its directory and doing

./blender

You need to do ./ to tell Linux that you mean the executable in the current directory (. is current in Unix); otherwise it’ll run the one apt installed. For easier access, add a Launcher (shortcut) to your launch bar, desktop, main menu, dock, or whatever.

redbyte, can you try downloading the blender that is linked with python 2.5 from the blender.org site?

the url (from one of the mirrors) is http://mirror.cs.umn.edu/blender.org/release/Blender2.47/blender-2.47-linux-glibc236-py25-x86_64.tar.bz2

i think that might fix your problem. let me know how this goes.

Okay there must be something seriously wrong with my install because I and I followed your (very well explained ;)) instructions perfectly.

If I double click the ‘blender’ icon. It does nothing. No error message, nothing.
When I run it from the terminal I get the familiar message:

./blender: error while loading shared libraries: libpython2.4.so.1.0: cannot open shared object file: No such file or directory

I’m stumped.

I’m doing the same things everyone else has done to run it, but it just doesn’t work!

Should I just cut my losses and do a clean reinstall of Ubuntu?

mmm
i tried to reply before, but i guess i cant post urls or links yet… so i will try this again without links…

redbyte, can you go to the blender site and download the version of blender that is compiled against python 2.5? that is on the right side of the block titled “Linux x86-64”.

the problem you are having is that blender is trying to look for python 2.4 when you have 2.5

i think this will fix your problem, let me know how it goes…

Aloyr you’re a genius, it worked!!

I didn’t even realise there were two versions of the same Blender version. How confusing!

Thankyou all so so much for helping me out. I’ve got a big smile on my face right now :smiley:

Now the real fun begins!

no problem, redbyte. I am glad I could help out! :slight_smile:

That was the problem!? I can’t believe I didn’t notice that! :o

Is there any chance, that the repositories will be updated? (to get the latest blender from there?) Or is it a repositorie which i need to add to the defaults which came with ubuntu? I can install it from the downloaded debain package no problem, but i like the automatic update feature of the synaptic, and if its not in my repos than it wont find the newer version when it comes out :frowning: Is it a solution for that?
Thx

You can download 2.47 from www.getdeb.net If you want it updated automatically add -

deb http://ubuntu.org.ua/ getdeb/

to

/etc/apt/sources.list

(System => Administration => Software Sources)

Thank you, works like a charm :slight_smile: