Can't Join

For some reason, when I try to join all the objects of my penguin model, his hair and eye brows seem to get pushed into the model, and he kind of gets a bit more square-ish.
The blend file is here:
http://www.savefile.com/files/351816
Thank you for your time.

WOW - well I’m glad you got all the parts arranged and composed but -

  1. Please please go through and follow and complete a tutorial like http://mediawiki.blender.org/index.php/Blender_Summer_of_Documentation#Ryan_Dale_-_Introduction_to_Character_Animation.
    It will give you a better sense for how to organize your work .

  2. I don’t know why you decided to have all the parts of the body as seperate objects from each other but generally you don’t want to model this way - especially when doing organic forms . If you want a new geometry in your mesh add it in EDIT MODE not OBJECT MODE . That way the new shapes are a part of one object , not each seperate objects like you have here .

  3. Ok to your current problem . The reason why you are can’t join the parts with out the “wierdness” that is happening is because you have have a bunch of modifiers you applied to your meshes some of which are not working well with the modifiers of the mesh you are trying to join (there was the eyes with the subsurf modifier stacked top to top - you don’t do that just increase the subsurf level to 2, also for some reason you have particle emitter set in the left leg and an unset soft body modifier on the right) .

You have (surprisingly) a couple of solutions to “join” your little friend . 1) just decide what you want to be the parent object - I’d go for the main head/body - select an arm then select head/body CTRL P and make parent, select other arm etc … So that after you have finished if you select the main head/body everything else will move with it and you can go on adding particles, softbody, liquid sim whatever without each seperate object affecting the other . Option 2) remove the unnecessary modifiers (or make sure all of them are the same) from objects and CTRL J to join your seperate meshes .
EDIT - I noticed that you don’t have a subsurf modifier on the beak - you might just want to parent that because you really have to CTRL P your hair/eyebrow emitters or else they won’t work (that is why your hair is disappearing) . In fact having seperate objects to emit particles is a good idea at the curent state of things in Blender .

Please go through some more documentation and actually try to reproduce a tutorial on your own - It will help you make what you want to make better if not faster .

Ok, This is a big help, Thanks a lot. And I have a few questions about what you just told me. What is liquid sim? And I didnt really understand exactly what you were saying in the edit, so do you think that you could possibly dumb it down for someone who is inexperienced in other words, a noob. Oh yeah, and the reason I made them all different meshes is because, when I started I didnt really know what else to do, but now I do. Thanks

Did you join all the objects to an object that didn’t have subsurf on?
You could’ve just left the eyebrows and the hair as a seperate object. I didn’t need the .blend file to see that, it’s just that many people make emitters seperate objects.

The Beack isnt subsurfed because it looks really stupid with it.

Then select the edges and crease them.

1). Select some edges
2). The crease option is in the edge submenu under the name ‘crease subsurf’

About the fluid simulation go here : http://mediawiki.blender.org/index.php/BSoD/Physical_Simulation/Fluid .
This capability was one of the reasons why I decided to work with Blender :slight_smile: - and DO THE TUTORIALS - there are some concepts and menus to input you won’t understand how to unless you go through them step by step .

About the Edit Mode - when you are in Edit Mode and you SPACEBAR and from the context menu add ->mesh type (cube,plane, etc it will always be a mesh type if you are editing a mesh, i.e. you can’t add a bezier curb or Nurbs surface if you are in Edit Mode with a mesh selected) . So that you could have added say the arms by adding two cylinders in Edit Mode and when you TAB out into Object Mode the arms would be considered as parts of one object not seperate ones like you have now . They don’t even have to be in contact - when any mesh (or any other object types) is created together in Edit Mode they are considered by Blender to be one object in Object Mode . It could be an entire room and its contents - if they at are all added in Edit Mode they are all parts of ONE object mesh .

You would do well to read up on the various “Mode” types and other basic concepts before trying to make things - It will make your life easier in the short and long run . Please try and do some homework and read up here : http://mediawiki.blender.org/index.php/Manual . OR if you really hate reading : http://blenderartists.org/cms/index.php?id=31#Video%20Tutorials (from this site) or http://blendernewbies.blogspot.com/2006/08/html-tutorial-neon-effect-in-blender.html
(noob site for Blender - almost all video)

As far as being a NOOB - I am also a “noob” . I started using Blender and 3D modelling only a few months ago myself - that’s why I have been trying to be helpful to you but you have to understand that people will just ignore you after a while if you keep asking basic interface questions and not take the initiative to learn how some of these things work . Your lucky you don’t post on the “Game Engine” section of the Forum :eek: - some of those guys can be brutal …

Ok, thanks a lot. You have been VERY helpful.

EDIT:

Then select the edges and crease them.

This didnt really do anything. The reason that the beak looks stupid is because it gets all jagged and stupid looking:
SInce this is only an edit, I will have to upload the jpg in the nex post:

Here it is:
Oh yeah and one more thing. What the heck is a Vertex Key? And how do I get rid of them. Because when I try to join all the objects, it says that it cant because it says: “Can join objects with vertex keys” How can I fix this problem?

Attachments