Can't make textures appear in viewport object or when I render

Hi,

Please Help.
I can make Textures appear on the preview sphere but can only makes colours appear on the cube I have in the viewport. It is the same when I try to render the colour appears but not texture.
Is there something else I have to do to make the texture appear on the cube.:frowning:

Blender 2.5: The things to look out for are that when unwrapping, you should have all vertices selected. After this, you need to be in a view mode which supports textures (e.g. Textured mode or Solid can both do it) and it can make a difference which shading options are selected in the [N] key panel. You may get better results with GLSL, Multitexture or Teture Face depending on which graphics card you are using. Make sure “Textured Solid” is active if wanting to see the texture in “Solid” view.