Can't make the hair comb backward

Hello, the problem I got is that the hair get inside the model when I try to make hair go backward like this:

As you can see the center of the haircut doesn’t has hair (They are inside intercepting the model).

The hair inside the yellow circle can’t comb more below, I only can comb outside of the circle but it get inside the model, it’s as if they were in low poly (low steps).

All this image is in 10 Path Steps (Max).

I hope you can understand me and thank for the answer.

You typically do mot need that many steps alltogether, but you need a few more near the roots. set the number of steps in the particle tab to 5 or 6 (or so), then in particle edit enable ‘point select mode’ and subdivide the first segment (multiple times, if needed).