Can't Reach to Wipe

Hello folks! I’ve been using Blender for about seven months, so I am still a relative Noob to the program. I’ve done pretty well so far, but i’ve reached a point that I cannot get beyond. I’m sure it is something simple that i’ve overlooked, but it has me totally stumped and I can go no farther.

I’ve built a locomotive for a railroad game. I have windshield wipers that are a child object of a door that opens. The wipers, a three piece setup, are independently controlled, but being that they are a child of the door, they also move with the door when it is opened. Now I have set this up exactly the same way in another modelling program and it works perfectly without any problems. However, with Blender, when the wipers are turned on, they fly off into space, as illustrated in the photos…

The setup in Blender - three piece wiper, child objects of the door:


Incidentally, the door handle is also a child, is independently animated, and works perfectly.

Now, here is what happens in the game engine when the wipers are turned on:


I’ve read just about every document that I can find on the Net about fixing this kind of problem, but nothing seems really get close to addressing the issue. The export logs have not helped either. Things I have tried to correct the problem:

  • Clearing the Parent, resetting the transform centers (pivot points), then re-Parenting the wiper objects.
  • Clearing the Inverse Parent - when done in Blender, the wipers move into the same exact position that they occupy in the game engine.
  • Parenting without inverse (Ctrl+Shift+P)

The really puzzling part is that at some point, the wipers did work correctly, so i’m thinking that I may have hit a key that has caused this issue to crop up.

Good looking model. Nice work.

The wipers, a three piece setup, are independently controlled,

How are you controlling it? Check Local / Global axis control setting. Since wiper is a child of door, it must be moving in its local axis.

I apologize for not getting back to you sooner on this. Been off the computer for several days.

The method i’ve been using was the Global axis. I’ve tried switching over to local, with no success. After several frustrating hours, I finally just deleted the wiper assembly and built another. Upon parenting to the door, I get the exact same results. I’m reading about Inverse Parenting, and from my limited understanding, the wipers are taking on the characteristics of the parented door, including it’s previous movements from one spot to another? Is this what could be causing this?

BTW, here is a better photo of the entire model, still WIP…


Attachments


It’s possible the doors also need to have the origin reset. Also try animating the wipers using delta transforms. I hope this helps.
SB