Can't render this project

Hello community, first time posting. Been trying to learn Blender on my own for the past 9 months. So far great, but now I’ve stumbled on a complete road block, which I’ve been trying to troubleshoot for two weeks without much success. I basically have this project looking just as I wanted on the viewport, but when I try to render it I get nothing but a gray screen. If I select an object it does render the orange selection point and it also exports in eevee, but it looks terrible. I thought if I made an account here and post the file, one of you gurus might find the problem and I could learn much more than just starting from scratch with different techniques.

Any help is much appreciated!

Project Files

If it’s any use, I’m on a Windows 10, i9 3.70GHz, 32GB and a GeForce RTX 3070

Hmm good and bad news.
I downloaded the file hit render and got this:

Looks fine to me.
If you are getting a grey screen it could be your GPU try switching to CPU in the render settings and see if it renders.

My specs and gpu are embarrassing! I would suspect a drivers issue.


Thank you for giving it a go! I tried your suggestions and I still get the same gray screen

But now you made me realise I might be pressing on the wrong thing.
So far I have always used this to render (red arrow):

Are you suggesting I use the Render found at the green arrow? I haven’t used it yet because it’s so damn slow. I updated the graphics driver,t no change.

That is your problem, the red arrow is for rendering your viewport and only works for eevee, to do a proper render from the camera you have to use the green arrow one.
So nothing wrong with your GPU it is simply that cycles does not render the “viewport render”
It only took about 11 seconds to render with your settings on my humble rig!
Cycles is a lot slower than eevee because it is a raytrace engine and does much more calculation.


Amazing! Well now I’ve learned something new! I’ve tried rendering twice now from the green arrow menu and it has crashed my whole PC twice. Any thoughts?

I am not sure why I only rendered one frame.
To render the animation I had to change the output destination to my temp folder make sure your output destination is valid on your system, I also changed the start frame to 1 (instead of 0).
I hit render animation and it renders (I stopped at frame 3)


Thank you again, especially for your patience! I’ve had one crash after another and the 1st blue screen of death I’ve ever had on this computer. I managed to squeeze out two frames by rendering images instead of the animation, but the floor is a mess! Not at all the lovely cobblestones I had before… Aaargh! I’m so confused and frustrated…

As per the output. Yes it is correct, this is not the first scene I’ve rendered, but it is the first time using cycles. I feel there’s something misconfigured somewhere…


Well I am afraid i am ruining out of suggestions (and I have to go to bed!), the last thing you could try is to set the rendering to cpu again using the green arrow (proper render option). That is if you have not tried it already. I am on Linux so the blue screen of death does not exist :laughing:
If you still have problems maybe there is some configuration wrong.
Bump the thread up with a reply and hopefully someone else will think of something.


Thanks again, maybe I should swap to my Ubuntu installation. If somebody suggests it’ll actually work better.

People say that Blender is faster overall on Linux, I’ve personally never noticed a difference but can’t hurt to try, right? :smiley:

1 Like

Couldn’t hurt, but I have a tiny HD on my Ubuntu and I would also have to install Blender. Plus there’s no driver for my graphics tablet… :cry:

1 Like

You have a very weird window setup… (four single windows and very big extra Outliner and a big screen i guess)… Had to use dont’ load GUI to know where i am…
Anyway: your file includes a 35MB wave file (not needed to show us) and is 49MB in size… Without it is only 13MB…
Anyway: using a i3 with 8GB and internal Graphics on linux (on this machine) 1:15 for the first image 1:40 after denoising with you settings… (no not hours and minutes but minutes and seconds)


Yes I forgot to mention that I also loaded the file with “do not load UI” because the separate windows annoyed me. It maybe worth you trying to get rid of that option/addon or loading factory settings before render.
Also check your temp file for any crash texts.

1 Like

Thank you very much everyone, I confess that I am at a loss. I tried moving to Ubuntu last night and although it worked far more stable for a bit, eventually when I was trying to add some lights it just completely froze! I’ve never had an Ubuntu machine freeze on me and I’ve had a lot of them on very dodgy hardware. I had to force shut with the box power button, this happened about 5 times in the course of an hour.

I take your point on the multiple windows. My day job is in music and working on multiple monitors is common. Never occurred to me that Blender might not like it. Also, I needed the sound file to synchronise the scene, forgot to remove it when I packed the project files, sorry.

I’m not getting anything on the temp file.

Finally, today I’m trying it on my laptop (a Surface Book 3), which is way lower in specs. And although it looks heavily pixelated on the viewport it seems stable and it is now rendering as I write this. I’d still like to add some more lights though. When I did my first animation a couple of months ago, I also had tons of crashes and was unable to render. Eventually I found a video that suggested changing the engine to eevee and using the Red arrow export. Then Blender worked like a charm. So there’s something wrong with the configuration of my cycles. I tried loading factory settings and appending the Scenes to the new project, nothing much changes… Like I said, at a loss…

This is very weird, you just can’t catch a break! If you want, I can render out your animation and send it over, I know that doesn’t solve your problem but you’ll at least have your end result :slight_smile:

1 Like

Aw…! You’re a sweetie! But I’d like to add more lights to the scene, get some candle-like lights coming out of doorways and windows and reflecting on to the street. I’m trying to do that now on my laptop, but it’s very hard on such a small screen. Is there a way to add a light directly onto a selected item/area?

1 Like

Sounds like you’re looking for a point light:

If you turn Custom Distance on and crank it down, you get a very nice candle-like effect :slight_smile:

1 Like

Oh yes, sorry, I do know how to do that. I meant adding or attaching the “object” Light (SHIFT+A) to a specific point or surface? As you see in my project I have these different houses at different distances, but when I try to navigate to the doorways or windows the screen just goes crazy, probably because of the size of the road…

OK lovely people, I’m not exactly sure what we did, but my guess would be that having multiple windows open was making Blender work 5 times as hard. It’s puzzling since none of the other windows had any rendering going on, they were just timeline, shaders and layers/outliner. All other programs I use allow you to put tool windows in other monitors without any impact on performance. Perhaps something to consider in the future for optimizations?

Again, thank you all very much for your help!

1 Like