cant run 2.5 on vista 64

sorry if this is not the correct topic to post this in but i could not find a suitable topic.

everytime i try to run the 64 bit version of 2.5 alpha 2 i get a error that says

The application has failes to start because its side-by-side configuration is incorrect. please see the application event log for more details.

anyone know what might be the problem?

nvm i fixed it. i just needed the microsoft visual c++ sp1.