Cant run GIMP

i downloaded GIMP 2.2 and have been using it for a few weeks. WHen i tried to open it the other day it wouldnt open. So now ive tried loading and unloading it and im in .dll hell. Does anyone know why i would go into this problem?

Mine being me specific? what dlls? you get a error message and if so what was it?

Help us to help you. :smiley:

the first failure was in iconv.dll and then in a different one, i dont remember. It said something about entry point. Basically it had an error with one dll and then when i tracked that down another would fail. I was wondering if there were similar problems elsewhere.

I figure ill just figure out what else has these .dll’s with that name and unload that program. Then try to reload gimp.

Have you changed any of it’s dependencies lately? For instance, did you install a new version of GTK recently?

I would try uninstalling GTK (if it’s still there) and then reinstalling it. It sounds like something happened to your GTK.

will try that