Can't save/export without something weird happening

I have Blender 2.49b with Python 2.6.2 installed. I’m quite the fan of the VOCALOID’s, so I decided to download the “Blender2PMD” thing and attempt to do some simple edits. With my Hetalia obsession, I tried to make Miku look like Igiko. I worked on the bangs and pony-tail-holders, got tired, saved it as a *.blend file, shut off my computer, and went to bed for the night. When I started up Blender today, the bangs reached done to her waist and her face got all deformed as if it was smash with a club covered in nails. Thankfully, when I selected “Recover Last Session” it got back most of what I did. I was able to re-do what I did last night and begin to work on the rest of her. I was tired and exported it as a *.pmd file to open in PMD Editor and see what she looks like so far. It didn’t export correctly, so I exported it as a *.3ds file to open in Metasequoia. I got this: Frustrated, I decided to export it as a *.pmd file and check it out in PMD Editor. Not too pretty: The *.blend file was just as pretty (but hitting undo after I saved it got things back, it just means I can’t save at the moment):

Can someone tell me what to do so I can save and sleep peacefully for the night?

Hi RandomCandy!

This is just a guess:
In the blender screenshot, it shows a modifier activated. Close it (Append or cancel) before exporting to other formats.