Can't sculpt a seamless tileable normal map Texture

EDIT: Nevermind! I found another tutorial explained better and solved my problem :slight_smile:

So, this is really giving me a headache…

I’ve tried many tutorials but the final texture never seems to tile correctly.

Here’s what I’m doing:

  • Creating a cube or plane, 8m x 8m
  • Subdividing it via Edge Subdivide 13-14 times.
  • Apply rotation and scale
  • Sculp mode in symmetry panel Lock X and Y, Enable X and Y tiling and 4.0 Offset for X and Y.
  • Sculpt the borders of the plaen or cube.
  • Bake it to a low poly cube that “encapsulates” the high poly sculpted one.
  • Apply the texture I just generated to a plane and stretch it’s uv face to get the repetition only to see it has seams and doesn’t actually tile perfectly…

I don’t know what I’m doing wrong, most tutorials on this just enable x and y tiling and get perfect seamless normal map textures.

Can anyone shine some light on this?

Thanks

Could you put a link for the better tutorial?

Maybe it could help me too.

Sure, here it is:

The trick is NOT to focus on sculpting the corners of your plane. Just make a big plane so that your tiling is not too restrictive, enable tiling and sculpt the middle or near the corners. Then make a low poly plane with half the dimensions of the big plane to bake on and put it in the center, unwrap and reset, then bake.

I wanted a big texture so I made a 16m x 16m plane, baked to a 8m x 8m plane and it was perfectly seamless.

It is a very good tutorial, just watch with a bit of patience.
If you have any difficulties, post them here and I’ll try to help.

2 Likes

Thank you for actual answering and sharing the link! I appreciate it.

You have my permission to mark your own comment as solution! :grin:

1 Like