Cant see animatable properties in 2.5

Hello, I’m trying to follow a tutorial on how to use the Graph editor in 2.5 . In the tutorial you can see the animatable properties on the right hand side of the graph editor like you used to in 2.49. I cant seem to do that in any version of 2.5 that I have there is nothing showing up on the right, no list of animatable properties. I have tried the view menu but nothing is helping. Can someone help me figure out whats wrong or what I am doing wrong ? Thank you for the help.

Hey Zeropoint,

Try hitting the ‘N’ key, nice shortcut to hide the properties panel. BTW, works in all of windows, like 3d View as well.

Cheers,
Tim

Thank you for the help, but hitting the N key only makes the panel appear and dissapear, I still don’t see any words.

The 2.4 - style list doesn’t exist because in 2.5 nearly everything is animatable, so the list would be enormous. By default there should be an outliner-syle window to the left of the F-curves that shows actions and curves for keyed objects (see below). Nothing will appear there if you haven’t animated anything. Try going to the default “Animation” screen from the dropdown at the top, and set some keyframes for an object.

The N key opens the properties display which lets you change features of a selected curve, such as modifiers etc.

What tutorial are you following?

Attachments


Here is the tutorial http://wiki.blender.org/index.php/Doc:Manual/Animation/Basic/Tools/Ipo_Curves_and_Keyframes

I am following it says for 2.5 at the top but it looks like they’re using pictures from 2.49 I guess.

I see what your saying, but how do I know what value I am animating then if I just hit Lmb key a curve will appear but how do I know specifically what It will animate ?

I mean lets say I’m trying to animate a particle system, I try to enter a key frame in the 3d view ( I Key ) all it says is the old loc rot etc obj type values. Nothing for particles though. Thank you very much for the help.

Actually strike that it doesn’t say that for particles in the 3d view I hit (I Key) and selected all available and got this message "No suitable context info for active keying set " Whatever that means.

That tutorial is for 2.45 :slight_smile:

In 2.5+, if you right-click on a property button, eg “Size” in the particles context, you will see Insert Keyframe. You can animate many many properties this way, even things like Blend texture type or color-ramp settings.

How or where do I find or create property buttons ?

Actually now that I know that was not for 2.5 tut I will look for a better one.

Just right-click on any button or slider in a Blender window and see if it says Insert Keyframe. If so, the property controlled by that button is animatable.

Thanks for all the help everyone. Much appreciated.

I found a good tutorial on animating in 2.5 by Ira Krakow here :

Turned out that every version of 2.5 that I had wouldn’t do any of that, I dl a new version and everything worked fine.