Can't see background images (New User)

Okay, this is an annoying problem, and I can’t find anything that helps.

I upload an image to use as a reference to make a character model, but it doesn’t show up on the 3D view. It was working fine the very first time I used it, but now it’s not doing anything. Isn’t it supposed to automatically pop-up on the screen as soon as you upload it?

Can anyone help?

I am in orthographic view…what am I doing wrong?

Ensure you are in orthographic view and the view set in the background image settings (front, top, right etc)
Toggle between orthographic and perspective view with numpad 5 (you’ll see the view name in the top left corner of the 3d view)

For more help show a screenshot of the whole blend interface and attache/link to your blend file

When you load your image you may want to pack it in your blend file so the link doesn’t get broken (File / External Data menu)