Can't see constraints ipos

I have a lot of constraints in my model. So many that when I go to select one I get a databrowse window. However, this shows only object ipos, and no constraints ipos. I’m told this is not a bug, but I can’t find anything that would give me control over which ipos are displayed. How can I see the constraints ipos so I can select the ones I need?

The only thing you can hang an Ipo on in constraints is the Influence. In the IPO window header’s Context menu (where it says “Object”) choose Constraint an you’ll see “Inf” for Influence. Select it and add an Ipo Curve with Ctrl-LMB on the grid or use the “Key” button in the Constraint tab in F7 to add keyframes.


I’m sorry, I haven’t explained myself very well. I have constraint (inf) IPOs coming out of my ears. What I’m trying to do is share them between separate constraints, so that two or more constraints will share one constraint IPO. (Is it better terminology to say “constraint IPO datablock”?) I could copy and paste the curves, but I would prefer to share the datablocks because I will need to edit them later.

Before, I clicked on the menu button by the datablock name, and a floating window came up with all the constraint IPO datablock names in it, and I selected one. Easy. Now I have so many that I’m getting a databrowse window. But this has only object IPO datablocks in it. I can’t find anything that controls what is shown in that window, either on the window’s menus or globally. How do I share the datablocks?

In the Ipo window, in Constraint Context, the default name for that datablock is “CoIpo”. So select the object or bone that has that IPO and (unless you’ve renamed it) it’ll be CoIpo with maybe .001. Select the object or bone you want to link that to and choose the same datablock (CoIpo) from the list and if it already has a constraint you’ll see the Users number increase by 1. If it doesn’t have a Constraint nothing will happen. If that’s the case then select the ob or bone without the Constraint and then Shft-select the one with, Ctrl-C >> Constraints >> select the one you want copied and click OK then link the IPO Datablock

Moving this to Animation.


Ah, yes, this is the point where I’m getting stuck. The list doesn’t contain CoIpo, or any constraint Ipos. It used to, when it was a floating window, but now it’s a databrowse window it only contains ObIpos. That’s exactly the problem I’ve got: I can’t select CoIpo because it isn’t showing up. I need to know how to adjust the databrowse window so it contains CoIpos as well as ObIpos (when I reported it as a bug they said the databrowse window should show all the Ipos). Or, conversely, what did I do to make the databrowse window only show ObIpos? I can’t find a control that does this.

This appears to be a bug ; once you exceed ~60 ipo’s, only Object or World IPO’s get shown in the IPO browser.

I’ll report it as a bug, and maybe Campbell or one of the other python wizzes can whip up a Python script to allow an IpO to be selected. I started to look at it, but I can’t figure out how to select and assign an arbitrary constraint IPO.


I must admit, I thought it was a bug, but it was rejected. I’m glad you agree with me. There’s certainly something odd going on. Thanks.

Oh? … so you already posted it to the bug tracker?

When? … do you have the bug tracker number? … did you post it under your same B.A. screen name ?

I just posted it (again ) :smiley:


The bug tracker number is 6624. Yes, I used the same name - shumphries.

It’s been moved to the “ToDo” tracker.

I found the entry and added some comments that hopefully will clarify the problem.

The problem is that the “SH-F4” databrowser is not behaving the same as the “IPO-window-databrowser”. The latter is trying to filter by IPO type, but it’s only working for Object or World IPO types.


Thanks Mike. I didn’t know it was a bug.


Thanks for the verification. In that case, I’ll have a look at what’s going on here…

EDIT:This has now been solved in cvs. What havok 14 characters of source-code can do :wink:


Wow, that’s great - thanks!

Next question: is there a work-around until that fix becomes available?

There is a Windows CVS (today) build here:

You’ll also need to download the FFMPEG libraries :

(It also includes FFMPEG (for multiplexing audio with video output)

(There are apparently problems with downloading those links using I.E., so you may need to use FireFox or a download manager instead).

I just tried it and the IPO thing is fixed :slight_smile:

Other builds /O.S’s are available in the testing builds forum

or on


Excellent - what service! Thanks, everyone.