Can't see objects in 3D view, help needed

After trying “Save default settings” button I can’t see the camera in 3D view. I tried to add a new camera, and I can see (1) Camera.001 text, but in 3D view I can see no camera. If I press n to see transformations, and press g to move the camera, nothing happens in transformations window. I can still render images and use the camera view. I reinstalled blender hoping to get old default settings back, but no, it didn’t help. Is there anything I can do or do I have to use older version of blender if it would work? (2.41 worked very well before this)

EDIT: Now I can’t see even the objects or lamps or anything, but I can still edit before this saved .blend files. They do work.

did you checked if the camera is on another layer?

Yes. If I add a object or a lamp or anything to the scene, I can see the (1) Cube.001 text but in the 3D window happens nothing.

Sonds serius…
Did this Problem ocure at some time after it worked, or did you just instaled blender?

If it worked in the past maybe reinstall blender.
Maybe install other display drivers.

I wonder if you saved the settings while in Local view. Try the Numpad-/ key.

BackBONE: I have used blender for about a year and never had any problems. Now after saving default settings I got this problem: I can only see the grid. As I told in the first post, I reinstalled blender and it didn’t help: default settings were the same as I saved them. I have to try install those display drives, but because blender has worked before, I don’t think that would be the problem.

CD38: Didn’t help. :-?

EDIT: Some screenshots:
http://img374.imageshack.us/img374/5259/screen0019fd.th.jpgDefault view
http://img374.imageshack.us/img374/1167/screen0029du.th.jpgAdded a box; edit mode
http://img374.imageshack.us/img374/6568/screen0032ma.th.jpgObject mode
http://img374.imageshack.us/img374/8886/screen0048bw.th.jpgInvisible suzanne
http://img374.imageshack.us/img374/7903/screen0058cu.th.jpgCamera view

I have to “up” this, because I really need help. :-?

up

In your Blender application folder should be a folder named “.Blender.” In this folder look for and delete the file “.B.blend.” It contains your default Blender settings. When you restart Blender, this file will be re-created with the “factory defaults.”

This is a strange problem that I can’t re-create. I still think it has something to do with Local View, as there are no layer boxes in the 3d header. Anyway let us know if the above works.

Thanks! I deleted .b.blend and now blender is working again! Great! :smiley:

@CD38 dude, thx! I just signed up to say THX to you haha, I’m a noob in blender and have spent like 15+ hours on this tractor model, and while I was so busy I pressed some button on my keyboard and like 50% of the objects went missing, but in Shading layout they were visible, I pressed / and it came back in the layout view. Thx again!

13 years :laughing:

1 Like