Can't see Rigify rig layers?


I have 2 rigify generated rigs inside 1 scene. If I select first rig, it will bring Rig layers panel automatically, but when I select second rig there is no rig layers at all.

I’d like to see FK/IK buttons and blend sliders, but is this rig broken or is it because I have 2 rigs inside same scene?


it isn’t broken. i guess when you append the second rig you have to append the too. it’s the script that register the interface of the rigs. and it’s different for each rig you generate.

Thanks for reply.

Any idea where I can locate that and how to execute it?

it is created when you apply rigify to the meta-human. it should be as internal text in the .blend file you created the rig. let’s have a look in text editor.

So should I open my .blend file using TXT editor inside Blender or externally? Sorry, I’m so lost with it.

no problem. blender has an internal text editor, and none or some attached files to it. these text files can be a link to an external text file, and also could be internal text. rigify create one of this internal files. imagine next sequence.
1.- i create a rigify rig in a blender file named A.
2.- i create another rigify rig in a blender file named B.
3.- i open file A, and append the rig within file B.

the first rigify has their interface controls, but not the B rigify.

Solution: append inside file A, and check as register (it should be executed when file is opened), and execute it too.

hope useful

1 Like

Thanks gmendieta for helping me out with this issue. Anyway, funny thing happened. Now I have two Rig Layers when I select appended rig and none when I select another rig. When I click Head button, both buttons will turn off…

Hey! I figured it out! Looking good so far. Thanks gmendieta!!!