Can't seem to bake materials to texture...!

Hey folks, having trouble getting this model to output the material colours to a diffuse map. I’ve added a diffuse texture, I’ve got it selected, I’m baking diffuse in Cycles Render options without direct and indirect lighting (so just colour)… but I’m getting an incomplete texture output, with only some parts baking.

I might be failing to see the forest for the trees on this, but currently I’m blocked. Can anybody suggest a solution?

zoeTexturingTest01001RS.blend (1.2 MB)

Hi.
To bake from multiple materials… you need to add and select that image texture in every single one of them.

Hi @StrayBillie !

I’ve added the image to all materials associated with the model, but now I’m just getting a black texture when I hit ‘Bake’. I know there’s something obvious I’m missing here, but I can’t seem to see it…!

zoeTexturingTest01001RS.blend (1.3 MB)

I don’t have any problems with your file, it bakes just fine :thinking:
Does it show any errors in the Info?

Seems fine in the console…


Can you see any issues with my settings? Thanks for taking the time…

–Rev

Sorry, can’t see anything wrong. I just opened your latest file, hit bake and it works… it worked for you before, right?
Did you try closing and opening it again? (not sarcasm)

Sigh - that absolutely worked. =D Thanks for your attention and suggestions!