Can't select bones in pose mode if "in front" is checked

searching for this on google, i’ve found a lot of people have this problem. Is it a bug or is it something i can fix?

I can select the bones with the circle and the lasso, but not with the box or tweak buttons.
I’m not importing a model or rig, this is something i’ve done from scratch and I’m still having the problem.

1 Like

It’s some interaction between “in front” property of armature (properties/object/viewport display) and fade geometry settings (from overlays dropdown) and you should try combinations of those.

I’ve heard that it should be fixed for 2.83, which is nice, because I continue to have problems with it, and fade geometry is no replacement for “in front.”

2 Likes