cant select non-child objects

Hello everyone.

So just before I ran into this problem everything was working fine then suddenly blender wouldnt let me select objects that werent a child of another object. I dont actually know if it’s not letting me select non-child objects, it may just be coincidence

I’m using blender 2.71 on elementary OS

EDIT: when I add a new object it will let me select that, but still not any of the other objects that arent children


Your post is a report about not being able to select non-child objects since there are no questions. But even if there were, you’re not using images to describe the problem so no one can follow along what you’re trying to do and where it fails. There is no .blend file attached to then find out the reason and suggest what to do to fix it.

This suggests that you might not know the difference between parent-child relationship and the difference between object mode and edit mode, adding to a object in edit mode which doesn’t add objects (there are no objects in edit mode), just more parts. But there isin’t even a slightest hint of what you’re doing so it’s just guesses.