Can't start the smoke on the frame I want!

Hi Folks,

I successfully got smoke to be puffed out of a particle system that is itself having its particles emitted only from a vertex group of the emitting mesh.

It worked fine when it all by default started from frame 1.

However, when I try to make the particle system (and therefore the smoke it emits) start on a later frame, the smoke ceases to be visible. The particles appear when they should, its just smoke is no longer coming from them.

It might be worth mentioning that the mesh is moving, animated by an armature at the later time I try to start the smoke, whereas when it all worked fine from frame 1, the mesh at that time was static.

Could it just be asking the viewport to show too much and is therefore a viewport rendering issue, or is the an actual functional reason it doesn’t work?

Also, I have noticed that once you add smoke, tapping thru frames slows down as Blender tries to composite each frame. I tried to remedy this by keyframing the smoke and particle effect’s in the modifier stack to have both viewport visibility and render visibility switched OFF until we reach the frame that the smoke starts, but even then, Blender is compositing every frame you tap through.

Found the answer. It was the caching parameters

oh, well thank you for that insightful fix, i’m certain the rest of the forum will find it helpful too.

:rolleyes:

Sorry! I had actually forgotten the small detail that caused the problem at the time of first replying to my own post. I had to refresh my mind what caused it then updated the reply above!