Can't Subdivide Face... why?

I have done a long search but I still can’t figure this out. I’ve narrowed it down to possibly being an ngon, though I can’t see how that could have happened… is there a way to tell?

Can anyone think of a good reason why I can’t subdivide this face. If I try a Loop Cut it attempts to cut all the geometry around the face, but it will not grab onto the face for some reason.

Cheers!

OK So I isolated just the face to make sure I’m not crazy. Can’t be an ngon if there are only four vertices, right? Unless I don’t understand ngons properly.

Anyway, still flummoxed over why it won’t subdivide!

Well just in case anyone is interested, I fixed this by simply deleting the face and then selecting the 4 surrounding vertices and closing the face (hitting F).

Would still love to know:

A) How to identify an Ngon, and

B) Why a polygon square with only 4 points cannot be subdivided.

Cheers!

well it would have been interesting that you shared the object :wink:

Your face may have had an extra hidden vertex. This can happen quite often. To fix geometry, you can try some of the Mesh > Clean Up tools.

Also Mesh > Merge > By Distance may remove 0 size faces and extra vertices.

To make sure you’re not dealing with ngons, select the faces you have trouble with, then go to Face > Triangulate Faces. This will turn ngons into triangles. Then go to Face > Tris to Quads to regroup triangles back into quads where necessary.

1 Like

Hey this is great, I just did this and worked great. Thanks!

  • Look at your first screenshot. The “center dot” of that face is not in the center of the face. That’s a dead giveaway. Though it isn’t a hard rule: perfect symmetrical ngons will have the dot in the center. But in your case it looks like you had extra vertex/vertices somewhere in the middle of the top edge.
  • Select the face and look at the bottom right of the status bar (if you’re on 2.90, right click there and tick “Scene Statistics” on). This will show how many vertices are selected (won’t be 4 if it’s an ngon).
  • Deselect everything and go Select -> Select All By Trait -> Faces By Sides. In the options set Number of Vertices to 4 and Type to Greater Than. This will select all ngons.

It can. But subdividing an ngon doesn’t cut edges through it, only adds vertices around the perimeter.

2 Likes

This explanation is everything, I didn’t know any of this. Thank you for helping to deepen my understand of Blender logic!

An Ngon has more than four vertices

As a quick tip, switching back to Vertex select mode will help show you where they are, unless they are very close to each other in which case the merge by distance option should work.