Car exhaust smoke in BGE?


I am trying to create a flow of exhaust smoke for a car game that I made. I have looked all over the web for how to create realistic smoke in the BGE, but everything I saw did not impress me. I am trying to achieve this exact effect:

Could you please tell me how to do it briefly step-by-step? If not, could you please post a simple .blend? It makes it a lot easier to understand what is going on.


Just a few semi-transparent planes.

Look for smoke and particles (not blender particles).

You can even find an old tutorial But you have to discover the material settings by yourself.

I tried it and I didn’t get the results I wanted. I want a flow of smoke from the exhaust. Since I know you are a professional in the game engine, could I ask you to kindly compile and post a simple .blend file? Thanks very much! :slight_smile:

Check out this “fire” behind this catapult projectile :smiley:

this could look even better with the right texture…


Random.blend (574 KB)

To have it look good, your going to need the smoke to be randomly scaled and randomly rotated, so it has some “noise” to it

I don’t know how to do that. Could you please post a .blend so I can understand how it’s done? Thanks!

Check out my videos, there is some smoke on a couple of them.
If that is what you after, i can do you a .blend

Yes please. That would be wonderful! :slight_smile:

Here you go. Tweak it till you`re heart desiresLINK REMOVED BY ME

Thank you very, very much! :slight_smile:

I just have one question. How do I change the amount of smoke that is flowing? I am tweaking the settings, but it is only changing the direction in which the smoke is ejected.

The always sensor. Change the pulse dude.

I just have one more ques. How can I make the smoke fade out? Because currently, it’s releasing the textured planes and clustering up, and this is really slowing down my game.

change the time box on the add object actuator. (will make them disappear). You can also play with animating the object color to make them fade slowly.

Thanks. But when I changed the time I didn’t notice a difference. It was set on 526, and I lowered it down to 0. But It still was floating in open space and not disappearing.

0 makes it last forever. 526 will be, at 60 frames per second, about 8 seconds.
I reckon about 100 or 75 will be about right, that’s around a second.