Car Glass Problem *new problem*

I’ve run into a problem regarding making my car’s glass. You can see it on the picture attached. The glass on the other side is very bright, indeed white, and I can’t figure out why. It’s the same if I render a picture on the other side of the car, then it becomes bright/white at the other side again. Any ideas? :slight_smile:

Attachments


Some things to check:
Do you have a lamp that is causing a spec that is very bright?
Do you have the depth factor set correctly for ray transparency?
Do you have a fresnel effect going on which you didn’t expect? (Try turning the model and rerendering to see if that is the case)
For debugging this problem: What happens when you turn off your lights? Have you tried rendering the model with a camera from the other side?

Thanks for the reply.

I tried setting the depth up to 6 and I think it helped as you can see in the attachment.

Now I’ve seen another problem, and that is the shadows within the car… Why is it so dark? I have a sun ligthning the scene and why doesn’t it go through the glass andilluminate inside the car?

Attachments


Is the “Traceable” button toggled for the glass material?

Yep, the tracable button is on.

You have to hit the TraShado button (right column of the Shaders tab) for the material that is to receive the transparency filtered light. I know, it seems a bit backwards, but activate it on any interior materials and it should remove the “full shade” effect currently created in the interior by the ray transparent glass.

Hope this helps,

John S.

Okay, I am almost finished with this project. I only need to render it now.

But again, problems. :confused:

I have decided to put the car on a background with a picture I took. But the glass is screwing it up again.

I use backbuf image and have set the glass to transparent with high samples and depth. I have selected RGBA in the render options.

Still, this happens. What is wrong and how can I get done with this?

PS. I have only rendered the glass/special material layer for that attachment picture… :stuck_out_tongue:

Attachments


bump Anyone?

If you are doing the composite as a post render process, try rendering the car to a file type that supports alpha(png, exr) and enable the alpha layer(RGBA) in the Render Format panel. Check that you have raytracing enabled as well.

Hope this helps.

I seriously can’t get this thing working! I just want the glass to be transparent and show the background image, how hard can that be.

Anyone who knows how this can be done?! :confused:

Do you have a high mirror setting on the glass?
Post a .blend so we can have a look at it.

If you are really stuck z-transp should fix it.

I thank you for your help. :slight_smile:

I have posted a attachment with a troubleshoot-version of my project with my last used settings.

Attachments

Mitsubishi Problem.blend (574 KB)

You’re gonna love this; I can’t find anything wrong with it. It is just showing the background colour. I think that is just how Ray Transparency works. You would have to either use Z-Transparency, or map the image onto a mesh plane behind the object or render the object separately with an alpha channel and composite it onto the background afterwards.
Or use the image as a world background(rather than a backbuff image).

I can’t get an example file uploaded just now, but try mapping the image as a World background mapped to view; should be a good place to start.
http://wiki.blender.org/index.php/Manual/World_Background