Car Rigging issues

(I’m using the most recent version of 2.93 for this, I did post this in the dedicated Rigacar thread, but I’m not sure if anyone will get back to me on that thread due to how dead it seems, so here we are.)

I’m having issues with the Rigacar addon and more specifically, trying to rig a gear shifter to the rig. This is what I’ve been trying to do: I rig the car as normal and generate the rig. The first problem is that for some reason, the rig moves the car forward from the cursor in the center on the Y-axis, and I don’t know why that is happening. The second is that I’m trying to rig up the gear shift – a separate mesh – using new bones generated from within the rig’s edit mode but whenever I do, it either breaks the rig (as I parented the shifter to the body mesh), or it ends up either displacing the mesh or turn out like this:

I’ve never had this issue before when rigging up cars, and I don’t know what’s happening here. I’ve tried every fix I can think of, and nothing really changes unless the change screws up the rig further. Even making the rig separate from the larger car rig and parenting both together doesn’t work right.

Here is the file for anyone who has a solution that I can use. I parented most of the other parts that didn’t need a direct bone rig, and they work perfectly fine, so I don’t know what I’m actually doing wrong.

Quick update on the situation: I tried to see if I could replicate the issue I was having here with another model, and I managed to be successful with it. Not only did the rig move my second example forward for seemingly no reason, but trying to add bones to the rig not only screwed up the parenting of the object (another gear shift lever) to the main object (the car body), it also screwed up the rig.

So can anyone explain to me what I’m doing wrong here, or has the Rigacar rig addon gotten to the point where adding new bones to the rig breaks it?

EDIT: Here’s a more detailed walkthrough of my issue, using one of the cars I usually like to rig as an example.

Here’s the car with the bones parented to the wheels and base (the interior components and doors have been parented to the body, as I usually do things). So far, so normal:

This is what happens after I click “Generate Rig” in both 2.93 and 2.83 (I tried a different version of Blender to see if the issue was with the version I was using, but it doesn’t seem to matter as it pops up in both, I’m using 2.83 for this btw. Top is before I generate the rig, Bottom is after):

From here, I’m trying to add a bone for the gear shifter and using the bone layer used in the original tutorials on the addon’s thread to add the armature I want for the object.

Here is what happens after I parent the bone and object together using “With Automatic Weights”.

So after moving the object in question back to the rest of the car, here’s what happens after I do that:

So I’ve went from there, either parenting the bone to the rig, or re-parenting the lever to the car body, but neither works, and at times, breaks the rig itself further. Above is one example of what happens, but there’s been others, like the shifter not following the roll control or the root bone. Or the weight painting itself breaks apart.

And after all this, that’s why I made this thread. As I don’t know if I’m doing something wrong, or if the addon itself is broken.

1 Like

When i attempt to rig a car my car will also seperate and/or rescale. I’ve tried to findout what im doing wrong,but to no evail. Haven’t found alot of answers this is the first time ive seen something similar happen. Do you know what could cause something like this initially without trying to attatch a shifter in aswell?

Before you ad the rig, please apply all transformations and make sure all the origins are snapped to geometry then parent everything to the car body, then apply the rig, that should work

Update to a year-old thread, but now the issue’s happening to me when using the Rigacar rig in 3.5. And now I don’t know if I’m still doing something wrong, or if this is a bug inherent to the plugin when using 3x versions.

UPDATE: Still happening, here’s what’s going on:
(rig not applied)

(rig applied)

I applied transformations for both the objects and on the rig in object mode, but it still decided to move forward on its own. Again, I don’t know what I’m doing wrong, or if it’s a bug present in the 3x series when the rigacar addon is used (using 3.6 here).

Sorry for the double post, but for anyone with the add-on enabled, here’s the file so you can take a look at it (Apologies for its size, I was working with a massively dense model).
Here’s hoping someone can figure this problem out.

This is what I did…
Set origin to Center of Mass > Surface
Select All…
Shift A > Add Car Rig…
Make sure to UN-Check Move Origin…

1 Like

ahkay, makes sense. I’ll give it a try.

Update, it works, I have no idea why I missed that Move Origin checkbox this whole time.

1 Like