Cartoon Edges

Is there a way to give some things in an image cartoon edges without giving it to everything?

Absolutely. You need to separate the objects with edges on a layer, and the objects without on another layer (press M in object mode and choose a different box).
http://www.bupla.com/blender/1.png

Here, the first cube will have edges, the cube on the right won’t.
http://www.bupla.com/blender/2.png

You should put your lamp on a third layer with the same method.

Then in your render window, in the “Render Layers”. Name the default render layer “Edges”. On this “render layer” select the layer of the left cube plus the lamp, just above “halos”.
http://www.bupla.com/blender/5.png
Add a new “Render Layer”, name it “without edges” (or else) and select the layer of the second cube, and the lamp. But in this case disable “edges” at the bottom of the panel. Like this :
http://www.bupla.com/blender/6.png

Ok, now the final part : NODES.

Open a Composites Node Window, add>input>render layer, two times (with the space bar). Add a AlphaOver Node with Fac = 1.00, and a CompositeNode as Output, make the links (see the picture).
http://www.bupla.com/blender/7.png
Don’t forget to active “Do Composite” in the render settings (just above “Play”) and “Edge” on the Output.
http://www.bupla.com/blender/9.png

http://www.bupla.com/blender/8.png
Is it clear or do you need more infos ?

it isn’t my thread:P but thanks, been looking something that explains the nodes a bit

Thanks this helps A LOT! :slight_smile:

Very nice. But unfortunately this method only allows you to place one layer over the other. You can’t have edged objects and non-edged object mixed together, overlapping each other back and forth.

However, I did find a way to do that some time ago, using nodes and different scenes, but if there’s an easier way I would love to see it.

Indeed Sago, you’re right. this method works for simple scenes. It would be too complicated with a mix of objects. Your way with different scenes works better.

Actually, I’ve just found a better node composition. I’ve got the impression that it works well, even with a mix of objects. The method is exactly the same as I said, but instead of a “Alpha Over” Node, you put a “Z Combine” one. Here’s the node window :
http://www.bupla.com/blender/a.png
and this is the render (blue cubes are on the Edge Render Layer).
http://www.bupla.com/blender/b.png

Tried that one too, but the overlapping of edged and non-edged objects looks horrible. This is because Z Combine doesn’t have Anti-Aliasing (yet). And, but I’m not sure about this one, Z Combine doesn’t take the edges into account.

So back to the drawing board…