Caterpillar WIP

Update Latest version attached

Here is something I’ve started working on in an attempt to better learn to use cycles materials:

I’m still working on fixing/ editing things, but one thing I’ve not been able to figure out is how to keep the pattern on the skin vibrant and while using SS. Any suggestions? (here is the node graph for the caterpillar)


Hi Benignbrett, the images of your post don’t show up.

SSS has been reworked for 2.77 in order to preserve skin details better. There is a new (default) option in the SSS shader called Christensen-Burley. The improvements are quite noticeable.

Hmmmm. Are the images showing now?

I have the SSS set to Christensen-Burley, but perhaps I don’t have the right order/combination of mix nodes then?


Yep, images do show now.

Some thoughts on your node tree.

I think you are overriding the SSS effect with the nodes on the right.

Furthermore I wonder, why you are using black as a color for subsurface scattering as I would expect black to result in no scattered light.

If you modeled your caterpillar at a real world scale a radius of 1 is way too much.

The scattering effect should be more visible on the outer rims of an object, therefore I would rather have tried a fresnel factor instead of a facing factor.

Looking at some references I think the translucency is a good approach, depending on the species. Maybe a tiny tad of SSS on top of that (instead of before) could add to it.

A huge time saver for the creation of node trees for Cycles is the node wrangler addon, which is shipped with Blender. After you enabled it in the user preferences you can click on a node while holding shift and it will create a viewer node (which is an emission node). This viewer node is connected to the material output. This way you can see the effects of each node or part of the node tree directly in the rendered viewport. This saves so much time.

Still thinking about the black SSS node. :slight_smile: If the purpose of this is to disable the scattering for the black parts of the skin - then a mask for the mix node would probably be better. You could control where the SSS is mixed in by a b/w mask. White would allow SSS whereas black would disable it. Different shades of gray would allow for finer control of the amount of SSS.

The wrangler addon looks cool, but it doesn’t appear to be working in version 2.77?

Also, question: were you saying that the SSS should be added in later in the material? So like, add emission to diffuse, then mix in SSS, then mix in glossy?

Yeah, you are right about the near black SSS node. It wasn’t doing much.

BTW here is what just my SSS rendered in the viewport looks like:


The wrangler addon looks cool, but it doesn’t appear to be working in version 2.77?

I use it under 2.77 and it is mostly working correctly. The only thing I noticed is an error message when I change the node type, but this message does not affect it’s functionality. The node type is still changed. The bug seems to be fixed already:

I still think your SSS is too strong. What is the size of your model?

Ah, I guess I was expecting a viewer of some sort of pop up while using the wrangler, but I figured out how quickly swap between the outputs.

Also, so I’ve changed it so that the caterpillar is about 1.5 cm while one blender unit scale is set to .001

So I’ve played around with some nodes and things, and I think it is starting to look better:



Just a few more tweaks and I think I’ll start working a bit more on the composition. I’m thinking of adding a little bit of orange to the scene by adding some some flowers.

Also, if anyone has any other suggestions, I’m all ears.


latest update:
Still working on composition


Love the colors, well done man!


So right now the background is just being added in in the compositor behind the render and I’ve noticed there is some really weird dark outlines showing up that makes them feel disconnected:

I assume it has to do with using a depth of field blur and putting a picture behind it, so I was wondering if anyone has any ideas on how to fix it.


Beautiful, I like it a lot! Keep up the good work!

Thanks a lot man!

So I ended up moving the background from compositing it in at the end to an image plane in the scene in order to get rid of the black artifacting from the depth of field blur. Its more of a workaround than a fix, but whatever.

Latest update:


Another update with slight changes:


Think I’m pretty close to done now:


Great job, look very natural.

Maybe something a little ‘wet’ where the plant is damaged… some minor sap?

Are you going for photorealism or cartoony?

Are you going for photorealism or cartoony?