Caustics for Cycles - NOT MNEE

Blender reflective and refractive caustics shader.
If you make some cool animation, please, post it here.
Or If there is anyone that can adjust the shader and make it better, please post it here :slight_smile:

https://youtu.be/tAikoNFM934

reflective-refractive.blend (4.1 MB)

51 Likes

This looks really cool! Is it designed to work with old Cycles as well, or just CyclesX?

1 Like

Every Cycles works.

4 Likes

looks amazing… thks

has you some water caustic’s example scene?

1 Like

water.blend (2.4 MB)
Here you are.

6 Likes

Thank you… works really nice with mesh deformation,

but I can’t to do it work with bump deform (deform channel).

Edit: Sorry… add deform = 1 works… :slight_smile:

4 Likes

The shader inside volumes:

10 Likes

Hi Alexander,

This is GREAT and AMAZING!!! You make our life come easily!!
Could you please give us more explanation about the setting of the node…like what is what?..like the “Focus Adj”

1 Like

It gives a different focus zone. Useful for round objects, where the focus point is very near, but we want more ''lazy" caustic. A little bit like IOR. It is for some kind of fine tuning.
Attenuation - how much fade effect. This is where the effect fades - the distance from the lamp in units.
Add deform - for artistic caustic distortion.

3 Likes

How standard roughness change the look of the caustics:

8 Likes

Wow this solution is awesome, thanks for sharing this,

1 Like

i love u man

2 Likes

How to use 2 or more lights with the shader?

12 Likes

The effect in volumes is amazing, i tried to put a cube with principled volumes in your reflective refractive scene i see the volume light and volume shadows but not volume caustics,maybe there is a step that i lost?

1 Like

volume.blend (2.4 MB)
Here is the volumetric scene:

4 Likes

Thanks a lot for the file

1 Like

Wow, just saw this now - it looks STUNNING!!! :star_struck:
Can’t wait to try it, as soon as I find some time.

Thanks a lot Alexander!!!

1 Like

How do I set them up after I “Add shader” them to the glass and use the light as object coordinates? Do I need to checkmark or change any more settings? Because I don’t know how to setup the refraction caustics…

1 Like

Holy hell, you did it dude

1 Like

Wait, I figured it out. I had “refractive caustics” checkbox turned off. I didn’t know the shader actually used them instead of just faking them :sweat_smile:
Now I’ve turned it on, and it works.

1 Like