Caustics in Mitsuba's Photon Mapping are Blotchy

When I render my simple scene (.blend: mitsuba_blotchy_caustics.blend (216 KB)) with Mitsuba 5.0 and photon mapping selected, the projection from my sphere onto the floor has lighter and darker spots. It is like scaled up noise. I turned on “Use Irradiance Cache” because my walls were very irregular in the same manner (now they are not). Turning up the caustic photons makes the spots smaller, but takes much longer and would require a very large number. Here is the render from a distance. It looks worse up close where I was trying to do my render, and it would look bad as well if I turned up the resolution.

Is there a setting in the render panels that I can change to smooth out the caustics like the irradiance cache did for the walls, or do I have to turn up the caustic photons? All the resources I can find for Mitsuba are in the PDF document, but it is in code and is hard to understand.