Caustics problem (shot glass)

I’ve search the forum before you even ask, and I did follow a very old tutorial. So now it’s come to this. For some reason I cannot get a crystal clear refraction on the floor. I did increase the photons from 200k to 400k and almost doubled the search. It did a little better, but I’m concerned if I up the photons again, it’s gonna take a horrendous time to render, is there another way?

Here’s all my settings.
[edit]
Also, why isn’t my floor texture showing up?
[/edit]

Attachments




No replys :frowning: cmon plz I gotta get this finished today. (Begging, sorry!)

Hi,

I’m guessing you’ve got a bump map on your glass - that will affect your caustics because you’ve not set No Bump. I think your caustics look pretty realistic. If you’ve not got a bump map I’m not sure what’s causing them to not be regular.

Make sure your image texture is in the right format - YafRay only recognises TGAs, JPEGs (and EXRs and HDR/PICs).

Hope this helps.

Nah, i don’t have a bump on the glass, any other ideas? I will look into the texture though for the floor.

Hi,

Hmm, if it’s not a bump map, do you have a bumpy mesh? Looking at the refractions there seems to be some irregularity - the result of some funky subsurfing? To be honest, I think it makes it look much more realistic than if it was completely smooth, but it depends on the look you’re going for. I can’t see anything wrong with your settings so my only guess is that the glass is a little bit bumpy. I guess I can’t really be much help!

TURN THE PHOTON BLUR UP, around .2. That’s the simple answer, your photons are currently too clean.

The mest is a subsurf’d mesh to make it look smooth. (Saves my graphics card a headache). I’m re-rendering a few tests now with the photon blur chagned.

[edit]
That worked fine, i’m gonna up the caustics again with teh blur to see some results, but at least all the little white spots are gone.
[/edit]

Thanks guys