Cell Fracture Gives Up Half Way Through

Hey, I’m trying to cell fracture a shard of glass in blender such that it will appear to smash when it hits the ground. When I try to Cell Fracture it, though, it seems to ‘cut out’ half way through, leaving me with a sort of half-finished cell fracture.

At first I thought it was a Mac glitch, until I tried it on a computer at school, and I had the exact same problem.

I’ve tried it on other objects, and I’ve decimated it to make it lower-poly, but I still get the same result.

What am I doing wrong? Any help would be great!

-iMac 2.5Ghz Intel Core i5
-V10.7.5
-24 GB RAM (I know I don’t need that much… Santa got it for me :wink: )
-Blender 2.65

What am I doing wrong? Any help would be great!
Attach or post a link to your blend file so other users can replicate what you see.

What do you mean by half finished. Only half fractured, or not fractured at all? Post a screen of the result.
It took me a while to realize that the fractured object is actually put on the next layer…

Thanks for your replies! I’ve got two screenshots to show what happens:



Original shard of glass


“half cell fractured”
Thank you!
I’ll upload a blend file too, please don’t laugh at my nooby technique! :slight_smile:

Hey gly, I’m afraid you have a very Nooby technique ;D but nonetheless I read somewhere (think it was on cgcookie) that you first have to make sure that ur subdivisions aren’t too high and there are no dups. Tho if that doesn’t work I suspect there may be a bug.

I have found that cell fracture often doesn’t work well on duplicated objects. I’ll explain more when i see u tomoz if u remind me but i’m assuming (unless i too have done something wrong) that u should consider submitting it as an official bug :DDD

cell fracture works best when the model is a solid volume without holes. its hard to see from the screenshots, but it looks like the model is only a 1 sided flat plane without depth? if thats the case just select all polys, extrude it to make it into a solid volume then run cell fracture again.
if you still have problems then make sure recursion level is set to zero. Recursion levels larger then 0 can cause similar problems (but usually only on more complicated models)

hope this helps

Hey ktysdal, thanks for your help. It does in fact have an applied solidify modifier, but maybe it is too thin still. I will make it a bit thicker, and try again. Thank you

Gilly

Hi Gilly, just happened to come across a guy at Blender HD who does a tutorial on cleaning up and fracturing complex meshes. Might wanna check him out :smiley:

-Hexbob :wink: