Cell fracture makes textures low res

So I have a simple asteroid model I’m trying to fracture with cell fracture, see here:


However, when I do a cell fracture (default settings), the result looks like this:


But not always! I’ve gotten it to work twice before, but I have no idea why it worked then and not any other times. Am I missing something obvious? I’ve spent a couple of days trying to solve this, and I can’t find any other threads about it, so I’m totally at a loss.

Assets come from Unity’s SpaceShooter demo.

I’ve just come on here to ask the same question…

I don’t have a solution, but if you click on one of your faces, you’ll see that all the verts in the UV editor have been moved into the same spot, basically shading the whole face the with the colour of the pixel at that position…

Quick test here does not show anything like described: http://www.pasteall.org/pic/show.php?id=89232

Edit a day later… So there’s no way you could post example blend files showing problem closely?

Okay I have a solution…

Last night I was playing around with my mesh (an imported .obj), trying various things - decimating down to a tiny amount of faces to eliminate the possibility that my mesh was too complex, auto sphere project UV mapping to make sure it wasn’t something weird with the original UVs, to no avail.

I then tried separating part of the mesh, a handful of polys and using the solidify modifier. Still no go.

So then I went a step further and separated just one face, and still had the same result. So it seems there’s something weird about the object itself.

How I eventually got it to work was I created a simple cube, and then joined them together with ctrl + J, selecting my mesh first and then the cube second, so that the mesh ends up being called ‘cube’ (Not sure if it matters which way round you do this.

Then I fractured, using the default settings, and found the texture on my mesh was as it should be. YEAH!

So then just delete the fractured cube and you’re good to go. :slight_smile:

Tedri Mark, you are a flippin’ genius. I’ve since learned that this is an actual bug in Blender, and I even added my understanding of it to the official bug in their tracker, but there’s been no movement on it for a very long time from what I can see.

Until they decide to do something about it, this workaround is brilliant! Thank you!!

eppo: the problem doesn’t happen with simple cubes, only with certain kinds of models. It’s an actual blender bug, hopefully they fix it one day, see here: https://developer.blender.org/T42907. Until then we have Tedri Mark’s awesome workaround!

Well… Did not know that, never really used regular textures - when the result is small-ish and procedural… Most fantastic workaround, really.

There is no bug, with cell fracture make sure you (apply scale/rot/trans Ctrl+a) before fracturing otherwise it fails.
Here is the pic from the file in the bug tracker and a kind of asteroid.


Ah… then it’s not applied Rotation values too which makes a mess out of UVs. I can blame just myself for not to resetting these on the Oeuf. And the story involving created Cube starts to make a sense. Remark for myself - RTFM next time :D.