Celtic Knot Generator

Here’s what I got in Windows (already showed TERMINAL from Linux - unless
there’s some other Console in Linux that I’m unaware of):

Regarding the other suggestion, I downloaded the addon from the github via
zip file. So, if it’s got a mistaken extension, it’s straight out of the zip file.

I copied the zip file over to the addons directory and installed from there.

After I installed I restarted Blender just to be sure. I searched for “celtic”
(without the quotes) - nothing.

Attachments


Slow down a minute - 106 KiB?! … the file is at most ~11k long. How did you download it? (I rather suspect that if you look at that file in Notepad or something, you’ll find it stuffed with HTML - definitely not the Python script).

Please try re-downloading the celtic-knot.py through right-clicking on the “Raw” button at https://github.com/BorisTheBrave/celtic-knot/blob/master/celtic-knot.py and saving the link… you should end up with a file which is no larger than ~11k (right now, version 0.1.1 appears to be 10,979 bytes). Anything significantly larger than this, and you have a download problem (which you should be able to verify by looking at the file in Notepad, and observing that it does NOT start with “# Blender plugin for generating celtic knot curves from 3d meshes…” etc etc).

Once you have a version of the file at the appropriate length, then try firing up Blender and see what happens.

Good luck! (^_^)x

Tried it on a second PC - WORKING.

Tried the SAME process on my PC - WORKING.

One second it’s not, despite everything I try.

The next second it is.

One difference, the size difference might’ve been due
to the ZIP file.

UNZIPPED (per instructions)
Copied
Installed.
Restarted

Worked.

Not sure what accounts for the difference.

Anyways - I’m up.

Thanx for your help and your patience.


P.S. - It doesn’t like Torus Knots…

System crashed twice with complex OR
simple (3,2 - default) - Curve converted
to mesh.

Again, Unkerjay, you need to be more precise about what you are doing. Please state step by step exactly what you’ve done. Ideally, a short script or recording.

I created a default torus then created a celtic knot and set a non zero width. It’s pretty slow but I end up with a million vertex polygon at the end. Machines with less memory may crash. The width setting is not for the faint of heart - don’t use it for complex meshes, you can do better if you manually set up the bevel object. If you’ve managed to make it crash without the width setting, then I would be interested.

Everyone else - i seem to have an unusually high number of people have difficulties installing the script. Am I missing something in the instructions?

I’m just pushing the limits. I’ve got 8 GB of memory on a system at least three years old. And I generally push the limits of my system let alone blender and your addon. I understand that a consequence of that is that my system will lock up, shut down and reduce me to “xkill” the offending program (Linux).

Using mesh torus’ I tend to have more success.

Also, I’m messing with largely untouched polyhedral waters. Polyhedronisme / JSModeler and Curves - Torus Knots Plus just makes
it easier to visit the nearest Torus Atlas for more largely untouched examples to play with.

So, it wasn’t as much a complaint as an observation. I don’t put the onus on you or your addon.

I just wanted to get it up and running. That much - done.

Heck I get the same thing everytime I push the subsurf modifier above 3. That’s not the addons fault or the authors
as much as the fact that the subsurf modifier just get’s REALLY complex REALLY quick. Throw that at an already complex
model and the inevitable happens.

So this one’s largely - don’t sweat it.

I get used to my system crashing simply because of what I have open at any given moment.

It’s the George Carlin rule of technology - “If you make room for more stuff. You’ll get more stuff.”
Likewise, even if I had a 32 or 64GB megamachine, I’d still have problems. I’m old enough to remember
56k dialup, then ISDN, then Digital. Moore’s law aside, it’ll never be enough.

When people could download images, they wanted audio/video, then streaming, then movies, downloadable CDs, DVDs, Blu-Ray.

“Enough is never enough”.

nuff said - I think.

Again - thanx.

hi, tested this addon again today, works great.
I do like the curve version I did earlier.
Recognition where it’s due.
BorisTheBrave, congrats, I’m updating add curve extra objects for Blender 2.79 release & I think this one is very useful.
Thanks for the cool addon.
look out for your name in the 2.79 addons release notes. :slight_smile:

Thanks for re-raising this; it’s a great addon. Here’s a very quick sketch using celtic_knot and manuelbastioni


I’ve just released a new update for this addon, bumping the version to 1.0.

The range of output has been increased a lot.

You can now generate ribbons:



And weave twills as well the plain weaves:

The coloring and UV options have also been improved, as you can see above.

You can find it at the same place as before:

Thank you BorisTheBrave.

Thanks for this good thing



Thanks for this awesome addon!

Wow. I so like shiny metal thingies…

Version 1.0 converted for 2.80

celtic_knot.py (37.1 KB)

2 Likes

maybe I’m doing something wrong, this addon on blender 2.80 last build, give me this error …

what’s the problem??
am on linux
Schermata%20del%202019-01-31%2010-21-58

Rename it to
celtic_knot_2.py
instead of
celtic_knot_2.80.py

it work, thanks!

No Problem, I´ve gotten the same error, nobody mentioned it before.

1 Like

New version fix for latest api changes

3 Likes

I’ve updated the github repo for 2.80, and also made a few tweaks. Thanks @ramboblender for your work.

2 Likes