centered texture with fade to the sides, cycles

Hey there,

i am trying to position an image on a rounded cube so that it is centered and the sides are faded.
Almost like in this screenshot:


Its not perfect so far. You can see some tiles on the side which are duplicates of the big image.
How can i hide those side effects?
I only want the image once in the middle. Here is my blend file:
texture_001.blend (549 KB)

You have overlapping UVs… (and didn’t pack the texture file, so I had to improvise…)
Left are the polygons you want the texture to appear on, right are the others: See how they overlap on the texture?


You need to move the UV polygons you don’t want to see the texture on “out of the way”, so they don’t cover the texture space:


Hey there,<br><br>you mean i had the normal texture and than additional the cycles texture? seems logic, ic hanged it and it worked now. confusing :). thanks for the help…<br>

EDIT
snip deleted for talking nonsense…

hey, are you sure? i did everything again from scratch. only selected the faces id like to get textured and it worked without moving anything away.

Well, it seems you already proved me wrong, then! :yes:

haha, no prob. in my first file everything was somehow double wraped. than maybe that could be a possible way to go. better would be to reset the wraping and start again maybe… thanks anyway…

You may try this.


Edit:It may need more tweeking in the color ramp as the image file was missing on your .blend
The imput RGB is unchanged ( meaning R.5 G.5 B.5 as it is when you creat it )
I mention it as you can’t see the value of this one in a screen shot, maybe it need to be twiked as well for the same reason.

Thanks Anrool, @IkariShinji allready solved it.
But how can I do the same in Blender internal? Is there a possible way to mask a texture with another?

Of course I had to miss the line when you said it was solved and see the one where IkariShinji said you proved him wrong.
No idea for BI.

:), in Blender internal I did it with layering 2 textures. One is the image and the other one is the gradient. at the gradient options i had to set the black color to alpha equal zero and check the stencil option. that makes the texture a mask. the downside of this is that it is not possible to mask individual layers with this method. seems that the gradient texture is masking all texture layers.
maybe there are more ways to do that. let me know if there are other ways.