CG Flex Rig - Realtime update of skin and hair color

Working my way through the Animation Toolkit videos, using Blender 2.67b on a Macbook Pro and version 1.2.1 of the Flex Rig. (I can’t create enough kudos for the folks who created the rig, BTW.)

One thing I’ve noticed - in the videos, when the narrator is fiddling with the hair and skin color settings, the colors update in real time in the 3D view. When I try to do the same, they don’t. The colors do appear changed when I do a render, but don’t dynamically update in the 3D view. Colors for the clothing, however, DO update in the 3D view in real time.

I have “Viewport Shading” set to “Texture”, and the 3D View’s “Display” properties are set to GLSL. (Switching the “Textured Solid” check box on and off there doesn’t seem to make a difference.)

If I change “Viewport Shading” to “Solid,” the character reverts to grey skin (as expected) - the clothes then follow the “Textured Solid” setting of the “Display” properties, but neither the hair nor skin change off the grey.

Any guesses as to whether this a result of some difference between the version of the rig used in the video vs the version I have? An issue with my settings? An issue with the capability of my machine? It’s far from a killer issue - I’m just trying to figure out what I might be done wrong.

OK, while reading another section of the Blender docs, a lightbulb went off. It was, indeed, my settings.

When I looked closely at the video, it turns out that they were using the “Cycles Render” option in the top toolbar, and then the “Solid” setting for “Viewport Shading.” I was using the “Blender Render” option instead of Cycles. When I changed my copy of Blender to the same settings used in the video, the behavior now matches that in the video. (Apologies for having doubted…)

I didn’t notice this originally because when my Mac’s mouse is over the Quicktime video player (I frequently pause the video to “play along”) the top bar on the player window overlaps the image of the top toolbar in the video, obscuring the Cycles setting.