Change bone Z-axis direction?

Hey,

I’m working on a model using Source engine jigglebones. The problem is that Source expects the Z-axis of the bone to go ‘along’ the bone, but I can’t seem to make that happen in blender. I’ve tried bone roll, but that’s not helping

Basically, I want to do this


How are you exporting the rig?

Hmm, it seems that hitting the Legacy Rotation button in the SMD exporter settings thingy did the trick.