Changed navigation shortcuts to MODO's and now I cannot navigate in Edit Mode

Hey everyone! :slight_smile: I’m completely new to Blender but not to CGI and VFX. I’ve been working in many packages over the years, from C4D to Maya to ZBrush to my current main and favourite package, MODO.

I’m intrigued by Blender but the fact that it ignores virtually all industry standards makes it somewhat cumbersome and frustrating to get into I’m afraid.

One example is that for over a decade now I’m used to Y being up. In every one of the aforementioned industry standard applications, the Y axis is up - yet in Blender Z is up. Is there a way to change this to Y being up?

I changed my navigation shortcuts to match those I’m used to from MODO (ALT+Left Mouse Drag for rotation, CTRL+ALT+Left Mouse Drag for dolly-in/-out, SHIFT+ALT+ Left Mouse Drag for translation).
Everything felt great for a moment, until I hit TAB to get into Edit Mode and now I cannot seem to navigate my viewport at all while in Edit Mode. Only when I TAB out into Object Mode again do my viewport navigation keys work again.

Where can I change this?

Hello Chris - I come from a similar background, having used other CG apps for about a decade and now transitioning to Blender. (on a side note, I can confirm after a few months of use that it is perfectly capable and totally replaced my previously used packages). The problem of custom navigation schemes affecting (or even breaking) other UX parts of the program is a bit tricky, as it is somehow double sided.

What I mean is that is that on one hand, a new user rightfully expects the switch from one navigation scheme to another to be one of the most basic things one can do in order to learn a new package ; but on the other hand, the hotkey paradigm of Blender creates special cases and interdependencies that only somewhat advanced users can understand. Summing it up briefly, hotkeys in Blender are both mode-dependant and mouse location-dependant, which makes their editing more complicated than it first seems. I think this is what caused your issue.

Here is an example of a setup causing similar issues, and the solution to solve them :

Of course this relates to Maya navigation and thus might not be completely relevant to your problem, but it will give you a good idea of how things work.

Bottom line : as someone who’s been there/done that, my advice to you would be to first get familiar with Blender for a few weeks or so without changing any of the shortcuts and viewport navigation settings ; and once you reach a point where you are fully familiar with the UI and UX concepts of the program, go on and edit everything to your liking. (sticking to the defaults forever is a bit pointless in my opinion).

While it doesn’t answer your question directly I hope this will point you in the right direction. Good luck !

To get a MODO-style viewport navigation, there’s actually no need to touch the keyboard shortcuts at all: Just enter the user preferences and check “Emulate 3 Button Mouse”.

(Note that this will be greyed out if you have “Select with: Left” enabled, but the checkbox can be checked regardless.)

@Pior: Thanks. I’ll try and follow your advice and see how it goes after a while. :slight_smile:

@IkariShinji: Wow, that’s great! Thanks a ton - so simple and so helpful. Now does this only relate to the viewport navigation or does is disable my middle mouse button entirely for all areas of Blender?

The middle mouse button is not actually disabled: You can still rotate with middle-mouse in the viewport or pan in the node editor.

BTW, one thing you will have to do is to work on some keyboard/mouse combinations if you have have “Select with: Left” together with “Emulate 3 Button Mouse” enabled: Loop select is e. g. Alt+RMB by default. With “Select with: Left” this becomes Alt+LMB - but that combination is now already used for viewport rotate due to “Emulate 3 Button Mouse”…

Great advice, thanks for the heads up!

By the way, why are there two entries for many if not most of the shortcuts?
For example here I’m getting two entries for mesh.loop_select:


The first (Alt Select Mouse) selects the edge loop and deselects everything else, using this command again on the same loop does nothing.

The second one (Shift Alt Select Mouse) can toggle (“Toggle Select” checkbox!) the selection and can add loops to and subtract loops from the current selection.